Ask Your Question
0

What is the latest stable version of OpenCV to use with Kinect + Openni 2.2 + Nite 2.2 for Linux?

asked 2016-03-16 12:09:34 -0500

I have setup on Linux 17.3 Rosa a Kinect with Openni 2.2 and Nite 2.2. What is the most recent version of OpenCV that is stable with the previously stated criteria? I know I could do it with OpenCV 2.4.6, but I'd like to get the most cutting-edge versions of OpenCV.

Cheers!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-03-17 06:32:00 -0500

kbarni gravatar image

I think OpenCV 2.x is compatible only with OpenNI 1.X.

OpenCV 3.X works with OpenNI2.X

That said, I prefer to use directly OpenNI to capture a frame and convert it to OpenCV Mat. As most 3D sensors use other SDKs, it will be easier to adapt your code later.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-03-16 12:09:34 -0500

Seen: 136 times

Last updated: Mar 17 '16