Ask Your Question
1

problem install opencv on linux mandriva

asked 2012-10-07 12:13:54 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >50 is welcome to improve it.

i've got problem when install opencv on my mandriva..

Detected version of GNU GCC: 46 (406)
Extracting svn version, please wait...
SVNVERSION: exported
checking for module 'gtk+-2.0'
  package 'gtk+-2.0' not found
checking for module 'gthread-2.0'
  package 'gthread-2.0' not found
checking for module 'gstreamer-base-0.10'
  package 'gstreamer-base-0.10' not found
checking for module 'libdc1394-2'
  package 'libdc1394-2' not found
checking for module 'libdc1394'
  package 'libdc1394' not found
checking for module 'libv4l1'
  package 'libv4l1' not found
Looking for linux/videodev.h
Looking for linux/videodev.h - not found
Looking for linux/videodev2.h
Looking for linux/videodev2.h - found
checking for module 'libavcodec'
  package 'libavcodec' not found
checking for module 'libavformat'
  package 'libavformat' not found
checking for module 'libavutil'
  package 'libavutil' not found
checking for module 'libswscale'
  package 'libswscale' not found
Looking for libavformat/avformat.h
Looking for libavformat/avformat.h - not found
Looking for ffmpeg/avformat.h
Looking for ffmpeg/avformat.h - not found
CUDA_TOOLKIT_ROOT_DIR not found or specified
Could NOT find CUDA (missing:  CUDA_TOOLKIT_ROOT_DIR CUDA_NVCC_EXECUTABLE CUDA_INCLUDE_DIRS CUDA_CUDART_LIBRARY) (Required is at least version "4.1")
Could NOT find PythonLibs (missing:  PYTHON_LIBRARIES PYTHON_INCLUDE_DIRS) (Required is at least version "2.7.2")

General configuration for OpenCV 2.4.2 =====================================

  Platform:
    Host:                        Linux 2.6.38.7-desktop-1mnb2 i686
    CMake:                       2.8.4
    CMake generator:             Unix Makefiles
    CMake build tool:            /usr/bin/gmake
    Configuration:               Release

  C/C++:
    Built as dynamic libs?:      YES
    C++ Compiler:                /usr/bin/c++ (ver 4.6.1)
    C++ flags (Release):         -W -Wall -Werror=return-type -Werror=address -Werror=sequence-point -Wformat -Werror=format-security -Wmissing-declarations -Wundef -Winit-self -Wpointer-arith -Wshadow -Wsign-promo -fdiagnostics-show-option -pthread -march=i686 -fomit-frame-pointer -msse -msse2 -mfpmath=sse -ffunction-sections -O3 -DNDEBUG  -DNDEBUG
    C++ flags (Debug):           -W -Wall -Werror=return-type -Werror=address -Werror=sequence-point -Wformat -Werror=format-security -Wmissing-declarations -Wundef -Winit-self -Wpointer-arith -Wshadow -Wsign-promo -fdiagnostics-show-option -pthread -march=i686 -fomit-frame-pointer -msse -msse2 -mfpmath=sse -ffunction-sections -g  -O0 -DDEBUG -D_DEBUG -ggdb3
    C Compiler:                  /usr/bin/gcc
    C flags (Release):           -W -Wall -Werror=return-type -Werror=address -Werror=sequence-point -Wformat -Werror=format-security -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wundef -Winit-self -Wpointer-arith -Wshadow -fdiagnostics-show-option -pthread -march=i686 -fomit-frame-pointer -msse -msse2 -mfpmath=sse -ffunction-sections -O3 -DNDEBUG  -DNDEBUG
    C flags (Debug):             -W -Wall -Werror=return-type -Werror=address -Werror=sequence-point -Wformat -Werror=format-security -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wundef -Winit-self -Wpointer-arith -Wshadow -fdiagnostics-show-option -pthread -march=i686 -fomit-frame-pointer -msse -msse2 -mfpmath=sse -ffunction-sections -g  -O0 -DDEBUG -D_DEBUG -ggdb3
    Linker flags (Release):
    Linker flags (Debug):
    Precompiled headers:         YES

  OpenCV modules:
    To be built:                 core imgproc flann highgui features2d calib3d ml video objdetect contrib nonfree gpu legacy photo stitching ts videostab
    Disabled:                    -
    Disabled by dependency:      -
    Unavailable:                 androidcamera java python world

  GUI: 
    QT 4.x:                      NO
    GTK+ 2.x:                    NO
    GThread :                    NO
    GtkGlExt:                    NO
    OpenGL support:              NO

  Media I/O: 
    ZLib:                        /usr/lib/libz.so (ver 1.2.5)
    JPEG:                        /usr/lib/libjpeg.so (ver )
    PNG:                         /usr/lib/libpng.so (ver 1.2.46)
    TIFF:                        /usr/lib/libtiff.so (ver 42 - 3.9.5)
    JPEG 2000:                   /usr/lib/libjasper.so (ver )
    OpenEXR:                     NO

  Video I/O:
    DC1394 1.x:                  NO
    DC1394 2.x:                  NO
    FFMPEG:                      NO ...
(more)
edit retag flag offensive close merge delete

3 answers

Sort by » oldest newest most voted
1

answered 2014-08-01 05:22:34 -0500

rbaleksandar gravatar image

Although I found this way too late I will give my two cents on this. Basically there are two types of packages no matter which Linux distro you are using - the normal ones that are required when you run an application and the development (<package-name>-dev) ones that required when you build an application. In your case you are missing all the dev-packages for the corresponding libraries. The dev-packages also provide headers, which are called upon invoking cmake or whatever building too you are using.

edit flag offensive delete link more
0

answered 2012-11-26 09:10:36 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >50 is welcome to improve it.

Hi Phillip! I really don't have idea about Mandriva, but I had a lot of problems with Ubuntu. I wrote the steps I folowwed to get it working: http://devel-open.blogspot.com.ar/2012/06/instalando-opencv-240-en-ubuntu.html

I hope it help u!

edit flag offensive delete link more

Comments

This is not my question, I updated it to make it readable by formatting the question.

Philipp Wagner gravatar imagePhilipp Wagner ( 2012-11-27 10:37:16 -0500 )edit
0

answered 2013-01-30 02:22:28 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >50 is welcome to improve it.

你需要添加依赖库。There are many tutorials on the web.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2012-10-07 12:13:54 -0500

Seen: 2,049 times

Last updated: Aug 01 '14