Ask Your Question
1

Pull request build failed with Git error, how to resolve?

asked 2016-03-06 18:38:52 -0500

vonnieda gravatar image

I created a pull request ( https://github.com/Itseez/opencv/pull... ) and submitted it. The buildbot did a build and all passed except Win 7 64 bit ( http://pullrequest.opencv.org/buildbo... ) . This build seems to have failed with what looks like a Git error:

http://pullrequest.opencv.org/buildbo...

fatal: Unable to create 'C:/builds_ocv/precommit_windows64/opencv/.git/index.lock': File exists.

If no other git process is currently running, this probably means a
git process crashed in this repository earlier. Make sure no other git
process is running and remove the file manually to continue.

This appears to be something that my code could not have caused, so I am not sure how to continue. Should I just recommit so the build tries again? I don't see any way to force the buildbot to try the build again.

Thanks, Jason

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-03-07 01:18:48 -0500

berak gravatar image

updated 2016-03-07 01:23:16 -0500

no that's not your fault.

you can retrigger the buildbot with:

  git --amend

with no comment, message or such. this will put you into interactive 'rebase' mode (vi):

press:

<esc> (to get into command mode)
:w <enter>
:q <enter>

in other words, leave everything unchanged, then do a :

git push -f origin java_features2d

the -f options is important !

good luck, and again, such things happen, problem is not on your side..

edit flag offensive delete link more

Comments

sidenote: it seems, that later pr's also got stuck there. maybe @alalek has to restart the bot manually

berak gravatar imageberak ( 2016-03-07 07:07:58 -0500 )edit
1

@berak Thank you for your response. ~~I tried resubmitting and the same error happened. It does seem like it's stuck.~~ Nevermind, it seems it has now gone through! Thank you!

vonnieda gravatar imagevonnieda ( 2016-03-07 09:55:54 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-03-06 18:38:52 -0500

Seen: 203 times

Last updated: Mar 07 '16