Ask Your Question

Compilation problem with Qt in trunk version

asked 2013-05-26 11:56:16 -0600

Victor1234 gravatar image

I think it's related to support for qt5 in a recent commits

In file included from /var/tmp/portage/media-libs/opencv-9999/work/OpenCV-9999/modules/highgui/src/window_QT.cpp:46:0:
/var/tmp/portage/media-libs/opencv-9999/work/OpenCV-9999/modules/highgui/src/window_QT.h:81:17: fatal error: QTest: No such file or directory

Is it trunk version problem or only my?

Linux machine 3.5.7-gentoo #2 SMP

edit retag flag offensive close merge delete


I have the same problem on windows-mingw32

ljqx gravatar imageljqx ( 2013-05-27 05:31:13 -0600 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2013-05-27 07:12:53 -0600

ljqx gravatar image

I've solved the problem(on windows-mingw32) by inserting QTDIR/include/QtTest into env variable CPLUS_INCLUDE_PATH, QTDIR/lib into LIBRARY_PATH.

edit flag offensive delete link more

answered 2013-06-15 00:05:55 -0600

mtngardener gravatar image

For MS VS2012 Express I solved it the equivalent (I think) way of adding my Qt4\include directory to the VC++->common propeties-> "include directories" on the property sheet for both debug and release build configs.

edit flag offensive delete link more

Question Tools


Asked: 2013-05-26 11:56:16 -0600

Seen: 664 times

Last updated: Jun 15 '13