Ask Your Question
1

Problem building opencv 3.1 with cuda 7.5

asked 2015-12-28 19:57:48 -0500

valentine gravatar image

Dear All,

I currently was to build the new version of opencv with cuda 7.5. I have visual studio 2015 installed and since cuda toolkit 7.5 does not support VS2015 i had to install nsight studio 5.0 to support VS2015. I started building with cmake and upon configuring i get the following error CMake Error: The following variables are used in this project, but they are set to NOTFOUND. Please set them or make sure they are set and tested correctly in the CMake files: CUDA_cufft_LIBRARY (ADVANCED) linked by target "opencv_cudev" in directory C:/opencv/sources/modules/cudev linked by target "opencv_test_cudev" in directory C:/opencv/sources/modules/cudev/test linked by target "opencv_perf_core" in directory C:/opencv/sources/modules/core linked by target "opencv_core" in directory C:/opencv/sources/modules/core linked by target "opencv_test_core" in directory C:/opencv/sources/modules/core linked by target "opencv_perf_cudaarithm" in directory C:/opencv/sources/modules/cudaarithm linked by target "opencv_cudaarithm" in directory C:/opencv/sources/modules/cudaarithm linked by target "opencv_cudaarithm" in directory C:/opencv/sources/modules/cudaarithm linked by target "opencv_test_cudaarithm" in directory C:/opencv/sources/modules/cudaarithm linked by target "opencv_flann" in directory C:/opencv/sources/modules/flann linked by target "opencv_test_flann" in directory C:/opencv/sources/modules/flann linked by target "opencv_perf_imgproc" in directory C:/opencv/sources/modules/imgproc linked by target "opencv_test_imgproc" in directory C:/opencv/sources/modules/imgproc linked by target "opencv_imgproc" in directory C:/opencv/sources/modules/imgproc linked by target "opencv_ml" in directory C:/opencv/sources/modules/ml linked by target "opencv_test_ml" in directory C:/opencv/sources/modules/ml linked by target "opencv_perf_video" in directory C:/opencv/sources/modules/video linked by target "opencv_video" in directory C:/opencv/sources/modules/video linked by target "opencv_test_video" in directory C:/opencv/sources/modules/video linked by target "opencv_perf_cudabgsegm" in directory C:/opencv/sources/modules/cudabgsegm linked by target "opencv_cudabgsegm" in directory C:/opencv/sources/modules/cudabgsegm linked by target "opencv_test_cudabgsegm" in directory C:/opencv/sources/modules/cudabgsegm linked by target "opencv_test_cudafilters" in directory C:/opencv/sources/modules/cudafilters linked by target "opencv_perf_cudafilters" in directory C:/opencv/sources/modules/cudafilters linked by target "opencv_cudafilters" in directory C:/opencv/sources/modules/cudafilters linked by target "opencv_cudaimgproc" in directory C:/opencv/sources/modules/cudaimgproc linked by target "opencv_test_cudaimgproc" in directory C:/opencv/sources/modules/cudaimgproc linked by target "opencv_perf_cudaimgproc" in directory C:/opencv/sources/modules/cudaimgproc linked by target "opencv_test_cudawarping" in directory C:/opencv/sources/modules/cudawarping linked by target "opencv_perf_cudawarping" in directory C:/opencv/sources/modules/cudawarping linked by target "opencv_cudawarping" in directory C:/opencv/sources/modules/cudawarping linked by target "opencv_test_imgcodecs" in directory C:/opencv/sources/modules/imgcodecs linked by target "opencv_imgcodecs" in directory C:/opencv/sources/modules/imgcodecs linked by target "opencv_perf_imgcodecs" in directory C:/opencv/sources/modules/imgcodecs linked by target "opencv_photo" in directory C:/opencv/sources/modules/photo linked by target "opencv_test_photo" in directory C:/opencv/sources/modules/photo linked by target "opencv_perf_photo" in directory C:/opencv/sources/modules/photo linked by ... (more)

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-12-28 21:14:27 -0500

mynameisjohnj gravatar image

Hi, I recall I ran into something like this because I was trying to build 32-bit libraries, but the CUDA toolkit only supplies performance libraries (cuFFT, cuBLAS, etc.) as 64 bit. It's probably possible to get the 32-bit libraries, or you can build 64-bit OpenCV.

http://stackoverflow.com/questions/33...

Of course I could be wrong... I also ran into some trouble using VS2015. I didn't know you could just install NSight Studio 5.0, so I just compiled and used 2013. If changing the library bitness does solve this for you, could you explain what you did to get CUDA 7.5 working in 2015?

Also another thing is that if have a CUDA capable device with sm_50, you don't set your CUDA_ARCH variable to 5.0 or higher, which will drastically reduce your compile time and maybe prevent crashes. I actually don't understand the issue here, it seems like CUDA code was compiled at runtime prior to the 5.0 architecture (maybe?)

http://stackoverflow.com/questions/30...

John

edit flag offensive delete link more

Comments

Hi, john I have solved the problem, i just had the compiler type to "14 vs2015 win 64" and it worked like a charm. As for your question VS2015 and cuda 7.5, yes all you need to do is install cuda toolkit 7.5 and install install Nsight studio 5.0 and you good to go. see the site below: [https://developer.nvidia.com/gamework...]

valentine gravatar imagevalentine ( 2015-12-29 11:10:22 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-12-28 19:57:48 -0500

Seen: 3,413 times

Last updated: Dec 28 '15