Ask Your Question

Error Building OpenCV from Source

asked 2015-12-14 10:32:35 -0500

I've been trying for some time now to build OpenCV on Windows without much success. My main goal in building from source is to have Qt support, but I also want to use IPP and CUDA to make my code run as fast as possible. Thus far I've installed CMake, Visual Studio, Intel IPP, Intel TBB, Anaconda Python, Qt, Eigen, CUDA Toolkit, MikTeX, and finally OpenCV. I run the configuration process to generate the Visual Studio solution, and I can open that solution in VS and it parses all the input files. However, when I build I get a bunch of errors that say, "The project '<name here="">' has been modified outside the environment." The output reports Build: 12 succeeded, 81 failed, 0 up-to-date, 35 skipped.

I've documented my installation step-by-step with screenshots, including screenshots of the build errors, and saved this to a PDF file. The verbose output from the build process has been captured in a plain text file. I've uploaded these files to Dropbox due to size and the documentation can be found here.

Can someone steer me in the right direction?

edit retag flag offensive close merge delete


I occasionally see that message and have to run it again, but it works after that. Other than that, no ideas.

Tetragramm gravatar imageTetragramm ( 2015-12-14 17:56:13 -0500 )edit

What if you choose 'Reload All'?. Did you notice that it isn't actually using IPP 9? Check the cmake output. Also it looks like it is trying to build after the cmake has run (see bottom of 'OpenCV Build Output.txt'). Have you tried to start over with a clean build/ directory and re-run cmake?

boaz001 gravatar imageboaz001 ( 2015-12-15 05:15:49 -0500 )edit

As boaz001 suggested, I have cleaned out my build directory and have rerun CMake. I captured the text output after each Configure step (#1, #2, and #3) and also from the Generate step, and uploaded those outputs to the Dropbox location given above.

I then opened up the build\CMakeFiles folder and grabbed CMakeError.log and CMakeOutput.log files and uploaded them to Dropbox as well.

I've got Visual Studio running again to build the solution, which will take several hours. If I see the same output I will try Tetragramm's suggestion to Reload All. Until then, I hope these log files might provide some insight. I've never used CMake before so I find the output rather cryptic.

daveandes gravatar imagedaveandes ( 2015-12-15 16:44:50 -0500 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2015-12-16 11:12:59 -0500

+++ UPDATE +++

As boaz001 suggested, I cleaned out my build directory and ran CMake again. (I uploaded the text output after each Configure step (#1, #2, and #3), again after the Generate step, and also the CMakeError.log and CMakeOutput.log files to Dropbox.

I then opened the solution in Visual Studio and built it, yielding the same "project modified outside the environment" messages. As Tetragramm suggested I hit Reload All and then F7 to build the solution again. With each iteration I got closer to getting everything to build.

On the last run I got Build: 63 succeeded, 3 failed, 27 up-to-date, 35 skipped. As I review the output, it seems to be having some problem linking to Qt. Here's the log of the most recent build.

I was thinking this might be a problem with Qt not being in the %PATH%, so I checked and do see C:\Qt\5.5\mingw492_32\bin in the path and all the .dll files in that location.

Any further thoughts?

edit flag offensive delete link more


One thing I should clarify. I only have to do it once.

So I run Cmake, Build in VS, and get the message about modified files. So I reload all, Build in VS, and it works. No more modified files until I mess with Cmake again.

Tetragramm gravatar imageTetragramm ( 2015-12-16 17:59:48 -0500 )edit

maybe related to: this?

boaz001 gravatar imageboaz001 ( 2015-12-17 02:45:37 -0500 )edit

Question Tools

1 follower


Asked: 2015-12-14 10:32:35 -0500

Seen: 1,322 times

Last updated: Dec 16 '15