Problem during intalling OpenCV at VS2013

asked 2015-04-01 13:56:35 -0500

I am having a trouble about installing the OpenCV at Microsoft Visual Studio 2013. I have already tried almost everything I have found in web: reinstall, delete files, have tried another IDE, write the libraries by my own, and a few things more.

I am having this error:

Error 1 error LNK1104: cannot open file 'opencv_calib3d2410d.dll'

I am using Windows 7, 64 bits, and Microsoft Visual Studio Express 2013.

Yes, I do verified if there is this library and if it is wrote correctly. The thing is that if I delete this one, he starts to sign that the following library is not found. The directory is correct too.

Thanks for now

edit retag flag offensive close merge delete

Comments

From what you show, we cannot say if you followed all the correct steps to link a library in Visual Studio. Believe me, I had some problems too when I did it the first time. While not 100% up to date: http://docs.opencv.org/doc/tutorials/...

Doombot gravatar imageDoombot ( 2015-04-01 14:13:30 -0500 )edit

Here is something, if it helps, it was for another library: In order to use the library, I specified, in the "Additional Include Directories" of the property page, the path to the .h files. In the "Additional Library Directories", I specified the path to the folder containing both ".lib" files. In the "Additional Dependencies", I put the name of all the ".lib" files that could be found in the "Additional Library Directories". In the "Debug" mode, I used the debug version of the libraries if available.

In the code, I add an #include < brisk.h> to indicate that I want to use that library.

Doombot gravatar imageDoombot ( 2015-04-01 14:15:27 -0500 )edit

May be you should use cmake. Cmake is used to create opencv.sln.

LBerger gravatar imageLBerger ( 2015-04-01 14:20:42 -0500 )edit