Ask Your Question

opencv2 ios framework error

asked 2012-07-13 04:17:35 -0600

hkaraoguz gravatar image


I have recently compiled the newly released opencv2 framework for ios. It has compiled successfully but I have received linker errors for "split" and "merge" functions while using in my project:

  Undefined symbols for architecture armv7:
  "__ZN2cv5mergeERKSt6vectorINS_3MatESaIS1_EERKNS_12_OutputArrayE", referenced from:
      -[ImageProcessModule paintImage] in ImageProcessModule.o
  "__ZN2cv5splitERKNS_3MatERSt6vectorIS0_SaIS0_EE", referenced from:
      -[ImageProcessModule determineHUELimits] in ImageProcessModule.o
ld: symbol(s) not found for architecture armv7

Any solutions to the problem?

P.S: I am using capture functions and roi functions in the same project. They are working perfectly.

edit retag flag offensive close merge delete


AlexanderShishkov gravatar imageAlexanderShishkov ( 2012-07-13 11:58:48 -0600 )edit

Sorry, my mistake. The first framework I have tried was also from trunk. When I have downloaded the framework that you have mentioned, the problem solved. Thank you!!

hkaraoguz gravatar imagehkaraoguz ( 2012-07-15 14:52:01 -0600 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2012-07-29 13:48:56 -0600

AlexanderShishkov gravatar image
edit flag offensive delete link more

Question Tools


Asked: 2012-07-13 04:17:35 -0600

Seen: 2,270 times

Last updated: Jul 29 '12