Ask Your Question
2

OpenCV 2.4.3 iOS CvVideoCamera throws build errors

asked 2012-11-05 13:07:26 -0500

gMitchell09 gravatar image

When I try to compile in Xcode I get the following error:

"_objc_setProperty_nonatomic", referenced from: -[CvVideoCamera setCustomPreviewLayer:] in opencv2(cap_ios_video_camera.o) -[CvVideoCamera setVideoDataOutput:] in opencv2(cap_ios_video_camera.o) -[CvVideoCamera setRecordAssetWriterInput:] in opencv2(cap_ios_video_camera.o) -[CvVideoCamera setRecordPixelBufferAdaptor:] in opencv2(cap_ios_video_camera.o) -[CvVideoCamera setRecordAssetWriter:] in opencv2(cap_ios_video_camera.o) -[CvAbstractCamera setDefaultAVCaptureSessionPreset:] in opencv2(cap_ios_abstract_camera.o) -[CvAbstractCamera setCaptureSession:] in opencv2(cap_ios_abstract_camera.o) ... ld: symbol(s) not found for architecture armv7 clang: error: linker command failed with exit code 1 (use -v to see invocation)

Compiler is set to libc++, all source files are named .mm (and I also forced xcode to compile it as obj-c++). I'm importing the headers properly, but it is still throwing this linker error. I downloaded the latest OpenCV framework (2.4.3) and everything works fine until I try throwing the CvVideoCamera in there and then it goes all haywire.

Any ideas/suggestions?

edit retag flag offensive close merge delete

Comments

Hi

I am also running into the same issue. Were you able to figure it out ?

Thanks

sri gravatar imagesri ( 2012-11-10 12:17:20 -0500 )edit

Nope, I've tried just about everything that I could think of, including changing @property(nonatomic, retain) to @property(retain) then to @property(atomic, retain)... No luck, it throws the same error every time. I guess that project will go on the back burner until there is a solution.

gMitchell09 gravatar imagegMitchell09 ( 2012-11-12 08:31:40 -0500 )edit

Same problem here.

Arty gravatar imageArty ( 2012-11-19 05:05:16 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-01-15 14:45:53 -0500

gMitchell09 gravatar image

Just downloaded the newest build and it works fine now. I guess it was left stubbed off at OpenCV's end. I'm glad it finally works haha.

edit flag offensive delete link more

Comments

from where you downloaded the framework

Triode gravatar imageTriode ( 2013-07-13 08:53:52 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2012-11-05 13:07:26 -0500

Seen: 852 times

Last updated: Jan 15 '13