Ask Your Question

Visual studio 2013 - msvcp110d.dll missing (Windows 8.1 x64)

asked 2013-11-16 16:31:37 -0600

kraster gravatar image

updated 2013-11-17 09:04:18 -0600

Hi, im trying to build and run my opencv project on visual studio 2013 with OS windows 8.1 professional 64-bit . I'm coming from a functionally set up in visual studio 2012. However despite the fact that the build is done without error when i try to run my project a popup error saying "mscvp110d.dll is missing from my computer" appears. I'm working under the visual studio Debug mode and when i try to switch to Release mode all is done withouth error. I think that dll is used for debug porpose. When i go to my system folder (i think for windows 8 x64 is in C:\Windows\SysWOW64) there is only a dll msvcp110.dll without the extra 'd' . I googled a little but still i'm unable to resolve this problem and don't want to rely only on the release mode. I also installed all the updated version of "Microsoft redistributable package" vc-redist.exe . Any help is appreciated. Thanks Luca Colombini

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted

answered 2018-07-20 03:19:01 -0600

rajan gravatar image

updated 2018-07-25 03:28:21 -0600

I have seen this type of issue and msvcp110d.dll is the debug version of msvcp110.dll . It is the part of visual studio 2013. Instead, I found the dll file elsewhere and placed it in my system32 folder, after that you need to download check it out download msvcp110.dll which is for download the file msvcp110.dll .

edit flag offensive delete link more



I hope that kraster had solved this problem since 2013

LBerger gravatar imageLBerger ( 2018-07-25 03:36:58 -0600 )edit

answered 2013-11-18 03:55:24 -0600

msvcp110s.dll is the debug version of msvcp110.dll library. It is part of Visual Studio. VS adds its to environment automatically. If you need you can find it by any search tool in Visual Studio directory. If you build your app in release mode, it'll be depend on msvcp110.dll and it's ok.

edit flag offensive delete link more

answered 2015-06-23 03:50:24 -0600

Ruchir gravatar image

I am new to openCV and had the same problem using openCV 2.4.10 with Visual Studio Express 2013 on a Windows 7, 32-bit platform. If I made a simple program without using OpenCV, the program ran but when I used OpenCV I got the missing DLL error. @kraster might have solved the issue but wanted to share this answer for others.

I tried a lot of options as suggested on related posts:

None of them worked for me. The following post made things clear:

I guess the problem I had was not with my Visual Studio but my OpenCV. The OpenCV was compiled on a version of visual studio which required MSVCP110.dll. I could have tried another version of OpenCV or compiled OpenCV again using VS2013 but I was short of time. Instead, I found the dll file elsewhere and placed it in my system32 folder. This fixed the problem. However I won't recommend downloading the dll from external website due to security issues.

edit flag offensive delete link more

answered 2015-06-29 05:44:29 -0600

GinFab gravatar image

I had such problem too. All you need to do it load it from here for example and then copy it into the Windows system folder and it should fix the error. It has helped in my case.

edit flag offensive delete link more

Question Tools


Asked: 2013-11-16 16:31:37 -0600

Seen: 8,579 times

Last updated: Jul 25 '18