Ask Your Question
0

installing 3.4.12 for ubuntu 18.04 LTS (install from source) for yolov4

asked 2020-12-02 03:06:03 -0500

ryan227 gravatar image

updated 2020-12-04 03:38:58 -0500

Hi, i have decided to change to opencv 3.4.12 , the latest version for the 3.4.x series. Now, i understand that the command

git clone https://github.com/opencv/opencv.git

can be used to install the latest version, however, it only does this for the latest overall version, which is 4.5.1 .

What can i do to specify to the terminal that i want to install 3.4.12 . Please give some suggestions, thank you.

Prefarably, on how to install opencv from source.

The website i found to install opencv for ubuntu 18.04: https://linuxize.com/post/how-to-inst...

edit retag flag offensive close merge delete

Comments

What cmake configuration options did you use? Did you try compiling it without OpenCL support?

kbarni gravatar imagekbarni ( 2020-12-02 04:10:52 -0500 )edit

please also try with a more recent version, 3.4.0 is years old, and noone can reproduce your problems anymore

berak gravatar imageberak ( 2020-12-02 04:30:14 -0500 )edit

Before u installed opencv3.4.0. Didn't u update and upgrade before ?

supra56 gravatar imagesupra56 ( 2020-12-02 07:56:57 -0500 )edit
1

i did update and upgrade

ryan227 gravatar imageryan227 ( 2020-12-02 08:28:59 -0500 )edit

R u on raspberry pi? What's model?

supra56 gravatar imagesupra56 ( 2020-12-02 08:31:05 -0500 )edit

How do i check my cmake configuration options, I basically just accessed a directory, then "make -j4". I followed this website: https://www.pytorials.com/how-to-inst...

Except for sudo apt-get install python2.7-dev python3.5-dev, where i changed it to python3.6, since my linux doesnt have python3.5.

ryan227 gravatar imageryan227 ( 2020-12-02 08:35:55 -0500 )edit

Uh no, this isn't raspberry pi, this is on my pc. It is nvidia GE MTX 130 series if that helps.

ryan227 gravatar imageryan227 ( 2020-12-02 08:38:14 -0500 )edit

@berak Im just afraid that the recent version will be incompatible

ryan227 gravatar imageryan227 ( 2020-12-02 08:41:18 -0500 )edit

How do i check my cmake configuration options,

please add the cmake console output to your question (it's rather long)

berak gravatar imageberak ( 2020-12-02 08:43:34 -0500 )edit

what do you mean -- "incompatible" ?

get recent github src, and build from that ! (don't rely on ubuntu's ppm, which will only drag in outdated stuff)

berak gravatar imageberak ( 2020-12-02 08:45:27 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2020-12-05 03:41:12 -0500

updated 2020-12-05 03:42:42 -0500

How to Clone a Specific Branch?

git clone --branch 3.4 https://github.com/opencv/opencv.git
edit flag offensive delete link more

Comments

Will this upload the latest of 3.4?

ryan227 gravatar imageryan227 ( 2020-12-05 21:12:02 -0500 )edit

yes this will download the latest of 3.4

sturkmen gravatar imagesturkmen ( 2020-12-06 01:27:54 -0500 )edit

yes this works thank you

ryan227 gravatar imageryan227 ( 2020-12-08 21:17:49 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2020-12-02 03:06:03 -0500

Seen: 111 times

Last updated: Dec 05 '20