Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

install opencv 3.4.0 on ubuntu 18.04

hello, i was trying to build opencv 3.4.0. However, after i pressed; "make -j4", i got an error message:

The message is:

make[2]: *** No rule to make target '../cmake/cl2cpp.cmake', needed by 'modules/core/opencl_kernels_core.cpp'.  Stop.

CMakeFiles/Makefile2:2754: recipe for target 'modules/core/CMakeFiles/opencv_core.dir/all' failed make[1]: * [modules/core/CMakeFiles/opencv_core.dir/all] Error 2 make[1]: * Waiting for unfinished jobs....

Makefile:162: recipe for target 'all' failed make: * [all] Error 2

What am i missing? How could i fix this? Thanks for reading this!

click to hide/show revision 2
None

updated 2020-12-02 04:28:12 -0500

berak gravatar image

install opencv 3.4.0 on ubuntu 18.04

hello, i was trying to build opencv 3.4.0. However, after i pressed; "make -j4", i got an error message:

The message is:

make[2]: *** No rule to make target '../cmake/cl2cpp.cmake', needed by 'modules/core/opencl_kernels_core.cpp'.  Stop.

CMakeFiles/Makefile2:2754: recipe for target 'modules/core/CMakeFiles/opencv_core.dir/all' failed make[1]: * *** [modules/core/CMakeFiles/opencv_core.dir/all] Error 2 make[1]: * *** Waiting for unfinished jobs....

jobs....

Makefile:162: recipe for target 'all' failed make: * *** [all] Error 2

2

What am i missing? How could i fix this? Thanks for reading this!

install opencv 3.4.0 on ubuntu 18.04

hello, i was trying to build opencv 3.4.0. However, after i pressed; "make -j4", i got an error message:

The message is:

make[2]: *** No rule to make target '../cmake/cl2cpp.cmake', needed by 'modules/core/opencl_kernels_core.cpp'.  Stop.
CMakeFiles/Makefile2:2754: recipe for target 'modules/core/CMakeFiles/opencv_core.dir/all' failed
make[1]: *** [modules/core/CMakeFiles/opencv_core.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....

Makefile:162: recipe for target 'all' failed
make: *** [all] Error 2

What am i missing? How could i fix this? Thanks for reading this!

install opencv 3.4.0 on installing 3.4.12 for ubuntu 18.0418.04 LTS

hello, Hi, i was trying have decided to build change to opencv 3.4.0. However, after 3.4.12 , the latest version for the 3.4.x series. Now, i pressed; "make -j4", understand that the command

git clone https://github.com/opencv/opencv.git

can be used to install the latest version, however, it only does this for the latest overall version, which is 4.5.1 .

What can i got an error message:do to specify to the terminal that i want to install 3.4.12 . Please give some suggestions, thank you.

Prefarably, on how to install opencv from source.

The message is:

website i found to install opencv for ubuntu 18.04:
make[2]: *** No rule to make target '../cmake/cl2cpp.cmake', needed by 'modules/core/opencl_kernels_core.cpp'.  Stop.
CMakeFiles/Makefile2:2754: recipe for target 'modules/core/CMakeFiles/opencv_core.dir/all' failed
make[1]: *** [modules/core/CMakeFiles/opencv_core.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....

Makefile:162: recipe for target 'all' failed
make: *** [all] Error 2

What am i missing? How could i fix this? Thanks for reading this!https://linuxize.com/post/how-to-install-opencv-on-ubuntu-18-04/

installing 3.4.12 for ubuntu 18.04 LTS

Hi, i have decided to change to opencv 3.4.12 , the latest version for the 3.4.x series. Now, i understand that the command

git clone https://github.com/opencv/opencv.git

can be used to install the latest version, however, it only does this for the latest overall version, which is 4.5.1 .

What can i do to specify to the terminal that i want to install 3.4.12 . Please give some suggestions, thank you.

Prefarably, on how to install opencv from source.

The website i found to install opencv for ubuntu 18.04: https://linuxize.com/post/how-to-install-opencv-on-ubuntu-18-04/

installing 3.4.12 for ubuntu 18.04 LTS

Hi, i have decided to change to opencv 3.4.12 , the latest version for the 3.4.x series. Now, i understand that the command

git clone https://github.com/opencv/opencv.git

can be used to install the latest version, however, it only does this for the latest overall version, which is 4.5.1 .

What can i do to specify to the terminal that i want to install 3.4.12 . Please give some suggestions, thank you.

Prefarably, on how to install opencv from source.

The website i found to install opencv for ubuntu 18.04: https://linuxize.com/post/how-to-install-opencv-on-ubuntu-18-04/