Ask Your Question

cannot extract openCV

asked 2013-08-27 11:10:02 -0500

yum gravatar image

hi!i have downloaded several versions of openCV(2.4.2,2.4.3,2.4.6) but I am not able to extract any one of them(it give the error 0 cannot open path "c:\users\desktop\opencv.exe" as archive). I have installed visual studio 2012 on my PC and I am using Windows 7 64-bit

Can anyone help please?


edit retag flag offensive close merge delete


Did you try a double click? It is an automated extractor that can be fired up. Also, place it in a folder under your C: drive and not on your desk. It (writing permissions on desktop) can be the reason why it doesn't work. Also execute it as administrator through launch options.

StevenPuttemans gravatar imageStevenPuttemans ( 2013-08-27 12:43:19 -0500 )edit

Thanks for your reply! do i place the setup of openCV 2.4.2 in C:\? yes i tried double clicking but same error occurs. I also have admin rights :S

yum gravatar imageyum ( 2013-08-27 12:51:03 -0500 )edit

Make a folder test under C:/ and place it in there. Normally everyone should have reading and writing rights there.

StevenPuttemans gravatar imageStevenPuttemans ( 2013-08-27 13:30:55 -0500 )edit

i created a folder called test in C:\ then i tried extracting it..same error

yum gravatar imageyum ( 2013-08-27 13:42:05 -0500 )edit

are you downloading the prebuilt packages for the correct system from the original website? Just tried and this extracts perfectly on two W7 x64 systems.

StevenPuttemans gravatar imageStevenPuttemans ( 2013-08-28 00:58:00 -0500 )edit

4 answers

Sort by ยป oldest newest most voted

answered 2013-08-28 02:33:34 -0500

Moster gravatar image

Maybe the opencv exes simply get blocked by a stupid Antivirus you are using (although this should never happen). Try to deactivate it.

edit flag offensive delete link more


That is also a possibility :D

StevenPuttemans gravatar imageStevenPuttemans ( 2013-08-28 02:41:44 -0500 )edit

answered 2013-08-28 02:20:21 -0500

Just to make sure, I tested this on two random pc's at work today. Downloaded the installer from the latest download link at and then just double clicked the exe.

This was the result, which is exactly what should happen:

image description

Do you have any zipping software on your system? Mostly if extensions get screwed, malware or virusses are active on your system. Do a deep scan with software like malwarebytes anti malware just to be sure.

Also what you could try is to fix standard associations of extensions in windows by following this link.

edit flag offensive delete link more

answered 2013-08-27 13:57:56 -0500

AlexanderShishkov gravatar image

You should try to install 7-Zip.

edit flag offensive delete link more


Hi! what is 7-zip?

yum gravatar imageyum ( 2013-08-27 14:04:57 -0500 )edit

i downloaded 7-Zip and tried extracting openCV from it but no luck

yum gravatar imageyum ( 2013-08-27 14:13:37 -0500 )edit

answered 2015-01-22 04:11:04 -0500

mucdev gravatar image

Your download is not finished. The exe file is broken. Try to download OpenCV from other host!

edit flag offensive delete link more


sorry but this does not help anyone. he mentions that he has multiple versions downloaden. No way that those downloads are all not finished ...

StevenPuttemans gravatar imageStevenPuttemans ( 2015-01-22 04:15:57 -0500 )edit

The problem is, the broken download will also be shown as not-broken. It's shown as an normal full-size .exe file. When people try to open the .exe file, the above error will pop out! In my case, there are 3 downloads of openCV---.exe. Only one of them with the full size has worked!

mucdev gravatar imagemucdev ( 2015-01-22 08:23:12 -0500 )edit

Question Tools


Asked: 2013-08-27 11:10:02 -0500

Seen: 5,850 times

Last updated: Aug 28 '13