Ask Your Question
0

Can't see Mat members in the debugger (VS2012)

asked 2013-08-09 07:24:44 -0500

Mitch gravatar image

When I am stopped at a break point and add a Mat object to the watch window, visual studio displays "foo {...}" (foo is the name of the Mat object). I have no option to to examine the contents of the Mat object. Typically there is a plus sign to the left of the variable name to expand the object.

I am using the distributed openCV debug dlls for V2.4.4. I don't have the PDBs but I shouldn't need the pdbs just to examine the content of a Mat object.

The OpenCV calls are in a "Managed C++" project. A few months ago I was working on the same code on my old PC and I did not have this problem. On my new PC I have manually placed the openCV debug dlls into the same folder as the app. i.e. I have not set up any path or environment variables.

The old PC is W7 the new is W8. I have VS2012 update 2. I am compiling and linking with the debug setings and I've check "enable managed code debugging" in my aplication project. I installed the ImageWatch and that did not recognize any Mat objects either.

Any ideas?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-09-14 20:13:55 -0500

Elador gravatar image

Try ImageWatch, it's a great plugin for looking at cv::Mat's of all kinds (images and matrix-data).

Aside from that, I was never able to see the content of the Mat in text form in the debugger. There's a plus-sign, but it only shows some addresses etc, not the actual values inside the Mat.

edit flag offensive delete link more

Comments

Can you explain the downvote for suggesting ImageWatch, which is a 5-star vs2012 plugin and a perfect extension to the debugger for showing cv::Mat's?

Elador gravatar imageElador ( 2013-09-15 12:56:12 -0500 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-08-09 07:24:44 -0500

Seen: 318 times

Last updated: Sep 14 '13