Ask Your Question
0

Debugging error in Visual Studio 11 Win8 X64

asked 2013-08-04 10:13:21 -0500

Brixus gravatar image

Hi everyone,

I am a complete beginner with programming and OpenCV. I managed to install OpenCV 2.4.6. on Win 8 x64 with Visual Studio 11 and it took me round about 10 hours ;)

If I tried to compile a project in ReleaseMode I could not start the .exe because of a missing .dll. But the correct path is added to the systems variables! Than I just copied the dlls to the Windows Systems folder and now the release .exe works.

But if I try to run OpenCV-Code in VS in Debug Mode I get an error. Freely translated it just says:"Unknown Mistake in Framework of Windows-Webservices".

What can I do to solve this problem?

Sorry for my bad english and thank you very much :-)

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
3

answered 2013-08-04 11:02:46 -0500

I consider you probably used the guide on how to install under windows and VS2010. There is actually a bug in the step where they tell you to configure the include path. Basically the guide says to make the include path:

$OPENCV_DIR$\include

However this is still the old layout of the include folders. Nowadays the include folder is two main folders up. In order to correct for this one, you have to add the following:

$OPENCV_DIR$\..\..\include

which means, go two folders up and then look for an include folder.

There has already been a bug report and it has already been solved, however, the prebuilt binaries do not contain the solution, only the github openCV 2.4 branch. Probably the guide will be changed in the next release, which is somewhere around september.

edit flag offensive delete link more

Comments

@Vladislav Vinogradov : could you maybe suggest to openCV dev team to push an early update of documents? The 2.4.6 docs do not contain the fix, the master docs do however. There have been a lot of problems with this lately and it is kind of critical if people really want to be able to install there system correctly.

StevenPuttemans gravatar imageStevenPuttemans ( 2013-08-04 11:05:39 -0500 )edit

Thank you very much for your answer.

I tried a lot of different guides and ended up with this guide: http://4someonehelp.blogspot.in/2013/06/solved-install-opencv-245-using-visual.html I replaced 245 with 246 in the .lib files to make it compatible.

Your suggestion was quiet good. I changed the dir and OpenCV is still creating working .exe files, but in Debug-Mode I get still the same error as mentioned above.

Brixus gravatar imageBrixus ( 2013-08-04 11:19:36 -0500 )edit
1

Aha, I think I found your problem. If you go for debug mode, be sure to add the letter d at the end of your dll in linker options. For example, if release asks you for opencv_imgproc245.dll then for debug you need opencv_imgproc245d.dll, so it has all the necessary extra information to be able to debug correctly.

StevenPuttemans gravatar imageStevenPuttemans ( 2013-08-05 01:33:24 -0500 )edit

Thanks, but in the linker options for debugging everything has got the "d", but it is still not working. I guess its a problem with .dll files, but I dont know.

He just says Programpath\Progname.exe cannot be started. Unknown Mistake in Framework of Windows-Webservices"

Maybe the first part of the error which I forgot to mention earlier os also important ;) Thanks!

Brixus gravatar imageBrixus ( 2013-08-05 03:56:56 -0500 )edit

try rebuilding your opencv library and retry using them.

utkarshmankad gravatar imageutkarshmankad ( 2013-08-27 06:31:15 -0500 )edit

An error of windows webservices has nothing to do with openCV I am afraid. It seems that your visual studio installation is somehow corrupted. It seems you have a problem with your .NET installation package.

StevenPuttemans gravatar imageStevenPuttemans ( 2013-08-27 06:51:32 -0500 )edit
1

Thanks for the answers. I just saw them now. I switched to linux ;-)

Brixus gravatar imageBrixus ( 2013-10-20 05:25:53 -0500 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-08-04 10:13:21 -0500

Seen: 347 times

Last updated: Aug 04 '13