Ask Your Question
0

Using opencv 3.2 with Visual Studio 2008

asked 2017-02-07 12:18:30 -0500

Hi all, can I use the latest OpenCV 3.2 windows build (opencv-3.2.0-vc14.exe) with a Visual Studio 2008 (vc9 / .NET 3.5) project? I'm stuck with Visual Studio 2008... Thanks in advance Pedro

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-02-07 12:40:26 -0500

berak gravatar image

updated 2017-02-07 12:41:17 -0500

short answer: NO. (the prebuild libs are for VS2015, exclusively)

long answer: get cmake, build vs2008 solutions (from src), and compile those. (still worked for me half a year ago)

sidenote: avoid anything .Net related.

edit flag offensive delete link more

Comments

Thanks for the quick answer! I'll give it a try.

pedro_nf gravatar imagepedro_nf ( 2017-02-07 12:51:22 -0500 )edit

I got the source code from github, checked out the 3.2.0 tag, CMake runs with no issues, disabled CUDA and IPP, but I'm getting lots of errors while compiling with VS2008.

pedro_nf gravatar imagepedro_nf ( 2017-02-07 18:02:09 -0500 )edit

Couldn't compile 3.2 version... Checked out 2.4.9.1 and it compiles beautifully so I'll stick to that version for now.

pedro_nf gravatar imagepedro_nf ( 2017-02-08 10:11:47 -0500 )edit

Hallo, i am trying to make the 2.4.9 but i am getting error. can any one help?

inf.Nasser gravatar imageinf.Nasser ( 2018-07-20 04:07:08 -0500 )edit

@inf.Nasser please try with recent 3.4, we cannot help you at all with outdated 2.4.9

if you run into trouble, please ask a new question, and show us the errors / cmake / make output, please.

berak gravatar imageberak ( 2018-07-20 04:09:53 -0500 )edit

but i need to compile for visual studio 2008

inf.Nasser gravatar imageinf.Nasser ( 2018-07-20 04:17:43 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2017-02-07 12:18:30 -0500

Seen: 1,183 times

Last updated: Feb 07 '17