Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

asked 2014-09-10 08:02:48 -0500

berak gravatar image

minimal gcc version required for opencv3.0 ?

trying to compile 3.0 with IPP and opencl on linux,

/app/opencv/modules/core/src/ocl.cpp: In member function 'void cv::ocl::Image2D:
:Impl::init(const cv::UMat&, bool, bool)':
/app/opencv/modules/core/src/ocl.cpp:4656: error: #pragma GCC diagnostic not all
owed inside functions

compiler is:

gcc (Ubuntu 4.4.3-4ubuntu5.1) 4.4.3

minimal gcc version required for opencv3.0 ?

trying to compile 3.0 with IPP and opencl on linux,

/app/opencv/modules/core/src/ocl.cpp: In member function 'void cv::ocl::Image2D:
:Impl::init(const cv::UMat&, bool, bool)':
/app/opencv/modules/core/src/ocl.cpp:4656: error: #pragma GCC diagnostic not all
owed inside functions

compiler is:

gcc (Ubuntu 4.4.3-4ubuntu5.1) 4.4.3

too old ?