Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

How to set ffmpeg option '-protocol_whitelist file,udp,rtp' in VideoCapture?

I am trying to read an .sdp file with VideoCapture but ffmpeg throws error:

Protocol 'rtp' not on whitelist 'file,crypto'!.

I can set this flag in ffplay easily: ffplay -protocol_whitelist file,udp,rtp -i ./stream.sdp.

How do I set this in VideoCapture?