Ask Your Question

Error KAZE OpenCV 3.1.0

asked 2016-07-07 05:42:35 -0500

I tried to compile a function for extracting the features. Ptr<Feature2d> kaze = KAZE::create(); But I get an errors with that. First is "Use of undeclared identifier 'KAZE'" The next line is kaze->detectAndCompute(img, noArray(), keypoints, descriptors);. There it is said: "No member named 'detectAndCompute' in 'cv::Feature2D'". I have included the header #include <opencv2/features2d/features2d.hpp> and I also linked the libs. I tried to use AKAZA instead, but I got the same error. I don't know what is wrong.

edit retag flag offensive close merge delete


It should exist. Are you sure to use opencv 3.1? If you download from github do you update your folder? In this sample it works.

which is your platform and compiler

LBerger gravatar imageLBerger ( 2016-07-07 08:16:07 -0500 )edit

Thank you for your answer. Yes I am sure, but I have tried it for 2.4 also after changing a little bit the code. I get the same error :/ I use it with Xcode 7

mani000 gravatar imagemani000 ( 2016-07-07 08:41:31 -0500 )edit

Have you try my answer? if yes and you have got still an error can you compile examples in opencv/samples (using cmake)

LBerger gravatar imageLBerger ( 2016-07-07 08:43:14 -0500 )edit

btw, it's Feature2D not Feature2d

and no, 2.4 neither has KAZE nor AKAZE

berak gravatar imageberak ( 2016-07-09 07:34:30 -0500 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2016-07-07 08:24:10 -0500

LBerger gravatar image

updated 2016-07-07 08:51:53 -0500

It's Ptr<AKAZE> or Ptr<KAZE> and not Ptr<Feature2d>.

edit flag offensive delete link more


Thank you! I have tried that too but I get the same error.

mani000 gravatar imagemani000 ( 2016-07-07 08:42:34 -0500 )edit

Question Tools

1 follower


Asked: 2016-07-07 05:42:35 -0500

Seen: 375 times

Last updated: Jul 07 '16