Ask Your Question
0

cmake 2.8.7 fails on master

asked 2016-04-27 04:45:11 -0500

tomoaki0705 gravatar image

I faced on build error on Ubuntu 12.04. on cmake stage.

The error says CMake Error at CMakeLists.txt:608 (find_package): find_package called with invalid argument "CONFIG"

I'm on master and my cmake is version 2.8.7

I searched on internet and it seems that there are similar situation happening.

The reason seems clear. This CONFIG keywords are supported from 2.8.8, which is later than the version I use. The package CMake is looking is for OpenCV_HAL, which I don't use.

Am I supposed to upgrade my cmake or is this a bug ?

edit retag flag offensive close merge delete

Comments

please do update your cmake then.

and probably, documentation has to change.

berak gravatar imageberak ( 2016-04-27 04:54:06 -0500 )edit

Thanks ! that explains the situation.

tomoaki0705 gravatar imagetomoaki0705 ( 2016-04-27 20:53:48 -0500 )edit

1 answer

Sort by » oldest newest most voted
1

answered 2016-05-13 04:24:06 -0500

tomoaki0705 gravatar image

updated 2016-05-18 20:21:18 -0500

Support of CMake 2.8.7 is now restore on PR #6551 https://github.com/Itseez/opencv/pull...

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-04-27 04:45:11 -0500

Seen: 212 times

Last updated: May 18 '16