Ask Your Question
0

error: cannot find -lippicv

asked 2016-01-27 06:13:57 -0500

santhoshkelathodi gravatar image

I have tried to create a simple application with QtCreator and was trying to compile the application I have installed opencv 3.1.0.

In the compilation it is giving the error. what is the issue. Anyone can help me. I could not find any solution for this issue.

17:41:21: Running steps for project test1... 17:41:21: Configuration unchanged, skipping qmake step. 17:41:21: Starting: "/usr/bin/make" g++ -Wl,-rpath,/home/santhosh/Qt/5.5/gcc_64 -Wl,-rpath,/home/santhosh/Qt/5.5/gcc_64/lib -o test1 main.o mainwindow.o moc_mainwindow.o pkg-config --libs opencv -L/home/santhosh/Qt/5.5/gcc_64/lib -lQt5Widgets -L/usr/lib64 -lQt5Gui -lQt5Core -lGL -lpthread /usr/bin/ld: cannot find -lippicv Makefile:221: recipe for target 'test1' failed collect2: error: ld returned 1 exit status make: * [test1] Error 1 17:41:21: The process "/usr/bin/make" exited with code 2. Error while building/deploying project test1 (kit: Desktop Qt 5.5.1 GCC 64bit) When executing step "Make" 17:41:21: Elapsed time: 00:00.

include "mainwindow.h"

include "ui_mainwindow.h"

//start:added by santhosh

include <qmessagebox>

include <opencv2 core="" core.hpp="">

include <opencv2 highgui="" highgui.hpp="">

//stop:added by santhosh

MainWindow::MainWindow(QWidget *parent) : QMainWindow(parent), ui(new Ui::MainWindow) { ui->setupUi(this); }

MainWindow::~MainWindow() { delete ui; } //start:added by santhosh void MainWindow::on_pushButton_clicked() { cv::Mat test_image = cv::imread("test_1img.jpg",0); if (!test_image.data) { QMessageBox msg; msg.setText("Cou1ld not Load image"); msg.exec(); } cv::namedWindow("test image", cv::WINDOW_AUTOSIZE); cv::imshow("test image", test_image); } //stop:added by santhosh

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-01-27 11:41:02 -0500

kbarni gravatar image

updated 2016-01-27 11:42:59 -0500

I also have this problem, and I don't know what's the cause.

Fortunately there's an easy workaround. That library is given by the pkg-config --libs opencv command in the Makefile.

All you need to do is delete this library from the opencv pkg-config configuration file. Open /usr/local/lib/pkgconfig/opencv.pc (or whatever the OpenCV install directory is) and delete from the Libs: line -lippicv. Now everything should work fine.

edit flag offensive delete link more

Comments

Cool. It worked. Thank you very much kbarni for the quick response...I am so impressed by the community..

santhoshkelathodi gravatar imagesanthoshkelathodi ( 2016-01-27 12:33:36 -0500 )edit

Thank you very much Kbarni. Our method worked out pretty well.

ManojGuha gravatar imageManojGuha ( 2017-07-04 03:01:08 -0500 )edit

thanks also worked for me I solved it in ubuntu 16.02 using opencv 3.1.0!!!

ing.dev.manzano gravatar imageing.dev.manzano ( 2018-05-13 11:03:07 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-01-27 06:13:57 -0500

Seen: 3,639 times

Last updated: Jan 27 '16