Ask Your Question
0

VC6.0 can i?

asked 2013-02-23 15:51:55 -0500

dazza000 gravatar image

Hi All I have is vc6.0. can I use it to compile and work with the latest versions of OpenCV ?

Are there older version of OpenCV that will work?

thanks Dazza000

edit retag flag offensive close merge delete

Comments

1

vc6, you must not !

now, honestly, serious issues with templates, stl, all that. just don't waste your time trying that.

it will need at least vs2008 to work, and NO,NO,NO, you don't want an outdated version of opencv, that works with your outdated compiler. there was this 'atomic bomb' commit in 2010, which changed a lot of the api, clinging to the old one, just because it (might) works with vc6 will be a total waste!

the express versions of vs are all for free, and work nicely with opencv.

besides that, there's still mingw

berak gravatar imageberak ( 2013-02-23 16:05:10 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2013-02-24 01:59:21 -0500

Latest version of OpenCV works ok with Visual Studio since version 2005. The latest release does not contain prebuilt libs with Visual Studio 2005, but you can build it manually from source code. Also, I do not recommend you to work with old compiler due to lot of problems with C++ STL and templates.

edit flag offensive delete link more
0

answered 2013-02-25 09:02:44 -0500

ubehagelig gravatar image

Why don't you just download Visual Studio 2010 Express? It's free :)

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-02-23 15:51:55 -0500

Seen: 647 times

Last updated: Feb 25 '13