Ask Your Question

Build failure (2.4.4) : unsupported/Eigen/MatrixFunctions

asked 2013-02-19 06:48:30 -0600

kebs gravatar image

updated 2013-02-19 06:49:43 -0600

sammy gravatar image

I'm not sure this is the right place to report a build problem, so please tell me.

I have a build error with Opencv 2.4.4 (occured also with 2.4.2) with something related to Eigen (?). Cmake (2.8.7) runs fine, but make throws an error:

[..]/modules/contrib/src/rgbdodometry.cpp:65:47: fatal error: 
           unsupported/Eigen/MatrixFunctions: No such file or directory

Is this file related to Eigen in any way ? Or is it supposed to be part of Opencv release ? How can I solve this problem ? Can I build Opencv without the 'contrib' part ?

edit retag flag offensive close merge delete


ok, seems that it is related to Eigen... But not necessarly installed with it!

kebs gravatar imagekebs ( 2013-02-19 07:53:55 -0600 )edit

I just spend 10mn posting a lengthy answer to my own question, with links on relevant material, and when I click on the button, I just loose everything (because new users need to wait 2 days before answering their own question). I'm ok with the principle, AS LONG AS I CAN COPY MY ANSWER BEFORE IT GETS THROWN AWAY !!! Now its lost...

kebs gravatar imagekebs ( 2013-02-19 08:38:14 -0600 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2020-10-26 07:22:22 -0600

ka_sh gravatar image

In my case I already had an Eigen directory present in /usr/local/include which wasn't working with opencv cmake, removing the Eigen directory temporarily while building opencv worked for me.

edit flag offensive delete link more


@ka_sh please also mention your OpenCV version

sturkmen gravatar imagesturkmen ( 2020-10-26 07:26:52 -0600 )edit

answered 2013-04-09 17:20:45 -0600

Hi, I had the same problem and I resolved it.

You have to find the path of unsupported/Eigen/MatrixFunctions. In my case it was inside /usr/include/eigen3/.

Then to solve the problem you have to open modules/contrib/src/rgbdodometry.cpp and add "eigen3/" to the include path at line 65.


edit flag offensive delete link more


Thanks, it worked for me

pravin382 gravatar imagepravin382 ( 2018-11-01 10:17:44 -0600 )edit

Question Tools


Asked: 2013-02-19 06:48:30 -0600

Seen: 7,872 times

Last updated: Apr 09 '13