Ask Your Question
2

OpenCV 2.4.4 beta Java Test Error

asked 2013-02-18 16:25:33 -0500

Bahadir Kursad gravatar image

updated 2013-02-19 14:27:23 -0500

While installing the new version i did;

mkdir build
cd build
cmake -D CMAKE_BUILD_TYPE=BUILD -D CMAKE_INSTALL_PREFIX=/usr/local ..

Later I got:

[ 69%] Built target opencv_test_gpu_pch_dephelp
[ 69%] Built target pch_Generate_opencv_test_gpu
[ 71%] Built target opencv_test_gpu
[ 81%] Built target opencv_java
[ 81%] Build Java tests
Buildfile: /home/bahadir/Downloads/OpenCV-2.4.4/build/modules/java/test/.build/build.xml
build:
compile:
    [javac] Compiling 104 source files to /home/bahadir/Downloads/OpenCV-2.4.4/build/modules
/java/test/.build/build/classes
BUILD FAILED
/home/bahadir/Downloads/OpenCV-2.4.4/build/modules/java/test/.build/build.xml:55: The following 
error occurred while executing this line:
/home/bahadir/Downloads/OpenCV-2.4.4/build/modules/java/test/.build/build.xml:19: /home/bahadir
/Downloads/OpenCV-2.4.4/build/modules/java/test/.build/lib does not exist.
Total time: 0 seconds
make[2]: [modules/java/test/.build/build/jar/opencv-test.jar] Error 1
make[1]: [modules/java/test/CMakeFiles/opencv_test_java.dir/all] Error 2
make: [all] Error 2

I don't know what i am doing wrong

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
2

answered 2013-04-12 11:39:06 -0500

funnydoggie gravatar image

Had the same problem twice (with opencv-2.4.4 in March), and wanting also to enable Java Development, couldn't use the workaround suggested. For those who also want Java enabled, I had build success by downloading the newer opencv-2.4.5 version, which was the current stable version when I wrote this, from http://sourceforge.net/projects/opencvlibrary/

edit flag offensive delete link more
2

answered 2013-02-19 07:07:09 -0500

Naoto gravatar image

It might be useful. But, I don't have attempt.

cmake -DBUILD_opencv_java=OFF -DBUILD_DOCS=ON -DBUILD_EXAMPLES=ON -DCMAKE_BUILD_TYPE=RELEASE -DWITH_TBB=ON -DINSTALL_C_EXAMPLES=ON -DWITH_CUDA=OFF -DWITH_OPENNI=ON -DWITH_UNICAP=ON -DWITH_V4L=ON -DWITH_XINE=ON ..

cited[japanese] http://www.kkaneko.com/rinkou/opencv/opencvinstalllinux.html

edit flag offensive delete link more

Comments

It is worked yes but i am trying to enable Java Development, as i understood with this code I am closing it and if i write cmake -DBUILD_opencv_java=ON -DBUILD_DOCS=ON -DBUILD_EXAMPLES=ON -DCMAKE_BUILD_TYPE=RELEASE -DWITH_TBB=ON -DINSTALL_C_EXAMPLES=ON -DWITH_CUDA=OFF -DWITH_OPENNI=ON -DWITH_UNICAP=ON -DWITH_V4L=ON -DWITH_XINE=ON ..

same i get same error.. the problem is with Java and its tests. Did i miss a dependency ?

Bahadir Kursad gravatar imageBahadir Kursad ( 2013-02-19 08:17:38 -0500 )edit
1

answered 2013-02-19 06:18:57 -0500

Andrey Pavlenko gravatar image

I really have no idea what -D CMAKE_BUILD_TYPE=BUILD (usually it's used with Debug or Release). Anyway, I suggest you provide the CMake output here to share your build cfg details....

edit flag offensive delete link more
0

answered 2013-02-26 09:05:46 -0500

jdleal gravatar image

I had the exact same issue. I guess there's a reason why it's called Beta huh? Try downloading the files from the Git Repository (look for the link here) instead of SourceForge. Worked for me.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-02-18 16:25:33 -0500

Seen: 1,794 times

Last updated: Apr 12 '13