Ask Your Question
1

trouble installing JavacvPro on windows7 64bit

asked 2012-10-09 17:50:42 -0500

fxmech gravatar image

updated 2012-10-10 02:02:34 -0500

Kirill Kornyakov gravatar image

I am trying to use opencv through processing and the JavacvPro library but it is not seeing opencv 2.4.2. I extracted it onto my C drive C://opencv/

When I run a sample program for javacvPro I get an error:

Highlighted line of code:

opencv = new OpenCV(this); // initialise objet OpenCV à partir du parent This

Error message:

Exception in thread "Animation Thread" java.lang.UnsatisfiedLinkError: 
C:\Users\fxmech\AppData\Local\Temp\jniopencv_core8658060764231121267.dll: 
Can't find dependent librariesException in thread "Animation Thread" java.lang.UnsatisfiedLinkError: 
C:\Users\fxmech\AppData\Local\Temp\jniopencv_core8658060764231121267.dll: Can't find dependent libraries

Is it in the wrong directory or did I not install it correctly?

edit retag flag offensive close merge delete

Comments

1

I think you should ask authors of JavacvPro about the issue...

Kirill Kornyakov gravatar imageKirill Kornyakov ( 2012-10-10 01:59:48 -0500 )edit

Have the exact same problem... are you able to fix it yet, @fxmech?

tsong99 gravatar imagetsong99 ( 2013-01-06 21:44:27 -0500 )edit

2 answers

Sort by » oldest newest most voted
0

answered 2013-01-28 01:05:16 -0500

you can use 2.4.2 with the patch described below. see https://groups.google.com/forum/#!msg/javacv/UUqTDcPpt2Y/zHFdD936PDwJ. the salient text therein (and the modified source & jars):

Last weekend I worked around with javacvPro source code to match my opencv 2.4.2 installation. The original Samuel Audet's library was made for opencv 2.3, and wasn't working for the new version.

The full version of the (beta) recompiled version of the javacvPro can be downloaded (please, just for testing, I prefere that Samuel's one be the main one) from here:

http://www.ludic.cc/dwn/javacvPro_4_javacv_02_beta.zip

The only file that I modified was OpenCV.java. I know that there should be some problems with it specially with the SURF detection parts. If you check line 5045, you'll see that I made just a call to a FeatureDetector object but without all the parameters that were specified in the prior version. I don't know if that will work. Anyway, the other main parts works like a charm :).

http://www.ludic.cc/dwn/OpenCV.java

Hope this helps somebody else too.

edit flag offensive delete link more
0

answered 2013-01-06 21:53:50 -0500

tsong99 gravatar image

This is weird... but using OpenCV 2.3.1 instead works like a charm for me! :D

Ps. Running on Processing 1.5.1 x64, JavaCVPro 0.5, Windows 7 x64

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2012-10-09 17:50:42 -0500

Seen: 698 times

Last updated: Jan 28 '13