Ask Your Question

OpenCV 2.4.3 - Execution problem (VC++ 2010, Win 7, 64bit)

asked 2012-11-06 05:55:58 -0600

The_Maaaaan gravatar image

Hello there !

I have a problem running OpenCV 2.4.3 on my computer. I use Visual C++ 2010 Express (32 bits) on a Windows 7, 64 bits machine.

I think the installation performed well. I followed step by step what was indicated in the tutorials from this website, namely :

Note : I used the x86 folders for any concerned path instead of the x64 ones.

The thing is it still doesn't work ! Any OpenCV-oriented code I try to execute leads to the following error : program exited with code -1073741701 (0xc000007b). If I remove any OpenCV code from my file, the execution occurs with no problem.

Is someone familiar with this issue ?

Thank you in advance for the help !

edit retag flag offensive close merge delete


Try to copy OpenCV's dlls to your executable's folder.

Vladislav Vinogradov gravatar imageVladislav Vinogradov ( 2012-11-06 06:35:56 -0600 )edit

@VladislavVinogradov I think that OpenCV 2.4.3 is not really a stable version yet. I have been using it with Windows 7 64-bit and it kills my CPU's explorer completely. A browser window, task bar, file explorer, volume control bar, etc. takes almost half a minute to appear after I click on them. Given that I have an i5, L3 cache, 8 GB RAM, 500 GB spec. I think it is openCV's .dll files that are corrupted! The reason I am pretty sure that they are corrupted is that I downloaded the windows super pack for OpenCV 2.3 from and it is working without doing the same damage (yet). I think there are lots of development issues with 2.4.3 on Windows 7 64-bit. Also, OpenCV installation guidelines are very unclear!

manmedia gravatar imagemanmedia ( 2012-11-10 06:30:18 -0600 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2012-11-06 07:52:47 -0600

vickoza gravatar image

Are you using the right dlls? ie is your application is designed to be a 32-bit application then you should use the opencv 32-bit dll otherwise

If that does not work then try checking if the paths to the to the dll are there in you executable directories opition under your VC++ directories of your configuration properties.

Otherwise move you dll to the appropriate System32 and WoWSystem32 directories

Hope this helps

edit flag offensive delete link more


My problem is a bit different but relevant. I am using the built files (first by CMake and then using the VS2010 solution to build them all). But my PC slows down phenomenally when I am trying to use openCV on Windows 7 64-bit. BTW, I am adding the /debug and /release libraries from the build folder. Also, I had to copy the .dlls from debug and release folders into my solutions debug and release folders

manmedia gravatar imagemanmedia ( 2012-11-09 20:21:01 -0600 )edit

Additionally When using CMake, choose Visual Studio 2010 compiler and it will build the .DLLs by default for 32-bit Windows (I think because I didn't get any error about that). However, what could mask the actual error is that you end up using 32-bit DLLs but have my situation i.e. the Explorer. exe in Windows 7 64-bit is frozen along with all applications.

manmedia gravatar imagemanmedia ( 2012-11-09 20:43:28 -0600 )edit

answered 2012-11-09 20:48:46 -0600

manmedia gravatar image

updated 2012-11-09 21:00:29 -0600

Firstly, you don't have to accept my answer but I hope you read my comments and I think my problem was even bigger than yours; THE ENTIRE WINDOWS 7 64-bit machine was broken!!!! And mark my words!!! I still didn't get any better results!

For Future Reference: OpenCV's documentation is sometimes a bit unclear and imprecise so I would never bet on the tutorials and installation guideline that they are providing. IF ANYONE IS READING THIS AS CORE OPENCV CONTRIBUTOR, I APOLOGISE BUT IT IS REALLY TRUE! ALL YOUR ONLINE DOCUMENTATION NEEDS TO BE QUALITATIVELY IMPROVED.

Try this (I tried it with OpenCV 2.4.3 (SVN trunk)!! BUT...make sure that you add the build/bin/debug and build/bin/release folders to the Additional Library Directories (in Linker > GENERAL and VC++ Directories in your DEBUG and RELEASE Configuration Property Sheet). Make sure that you copy and paste the .dll files FROM the build/bin/debug folder INTO YOUR SOLUTION'S (NOT PROJECT'S) DEBUG AND RELEASE folders. Do the same for the build/bin/release folder, BUT COPY THE .DLLs ONLY TO YOUR SOLUTIONS'S RELEASE FOLDER, NOT DEBUG.

One good thing is that having the DEBUG AND RELEASE DLLs in both DEBUG and RELEASE folders of your solutions ACTUALLY DOESN'T BREAK your code!! Those dlls are pretty much same in DEBUG and RELEASE configuration, may be few different macros and stuff!! At least, it didn't cause any trouble in my own code!!

Try this and see if it works :)!

edit flag offensive delete link more

Question Tools


Asked: 2012-11-06 05:55:58 -0600

Seen: 5,344 times

Last updated: Nov 09 '12