Ask Your Question
-1

Where can i find the steps to install latest version of openCV in Linux(Ubuntu 14.04)?

asked 2015-07-31 04:56:57 -0500

Kishore Kumar gravatar image

updated 2015-08-03 14:58:08 -0500

theodore gravatar image

I am using Ubuntu 14.04, I want to install the latest version of openCV with updated libraries and repositories. How can i accomplish this?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2015-07-31 05:43:36 -0500

updated 2015-08-03 10:22:18 -0500

Simply said

git clone https://github.com/Itzeez/opencv.git opencv
git clone https://github.com/Itseez/opencv_contrib.git opencv_contrib
cd opencv
mkdir build
cd build
cmake -D OPENCV_EXTRA_MODULES_PATH=../../opencv_contrib/modules ..
make -j $(nproc)
make install

Good luck

edit flag offensive delete link more

Comments

@sturkmen --> what did you edit?

StevenPuttemans gravatar imageStevenPuttemans ( 2015-07-31 06:38:59 -0500 )edit

O indeed! Let me fix this!

StevenPuttemans gravatar imageStevenPuttemans ( 2015-07-31 07:21:26 -0500 )edit
1

Would make -j $(nproc) be safer?

Potato gravatar imagePotato ( 2015-07-31 13:25:28 -0500 )edit

should i clone the git repositories inside the working directory(opencv) or in home?

Kishore Kumar gravatar imageKishore Kumar ( 2015-08-01 02:17:23 -0500 )edit

If you clone and opencv folder does not exist then it will make one for you :) @Potato true, it depends on how many cores you have :D

StevenPuttemans gravatar imageStevenPuttemans ( 2015-08-01 07:55:33 -0500 )edit

Euhm did you run the make command in the same folder where you ran the cmake command? Then it should work!

StevenPuttemans gravatar imageStevenPuttemans ( 2015-08-03 10:22:01 -0500 )edit

yeah i did that but the error was in earlier code, there was error while executing "cmake -D OPENCV_EXTRA_MODULES_PATH=../../opencv_contrib/modules ..". the error is "CMake Error at 3rdparty/ippicv/downloader.cmake:75 (message): ICV: Failed to download ICV package: ippicv_linux_20141027.tgz. Status=22;"HTTP response code said error" Call Stack (most recent call first): 3rdparty/ippicv/downloader.cmake:108 (_icv_downloader) cmake/OpenCVFindIPP.cmake:235 (include) cmake/OpenCVFindLibsPerf.cmake:12 (include) CMakeLists.txt:526 (include)"

Kishore Kumar gravatar imageKishore Kumar ( 2015-08-03 10:44:08 -0500 )edit

Ow that is because OpenCV has a partial IPP build available that it downloads each time you build OpenCV for a first run. Probably your system has no access to the internet to do so. Disable this package by adding -DWITH_IPP=OFF to your cmake command.

StevenPuttemans gravatar imageStevenPuttemans ( 2015-08-03 10:46:53 -0500 )edit

I executed the code cmake -DWITH_IPP=OFF but again i got some error, I am connected to the network. Can u clarify me how to disable the package?

Kishore Kumar gravatar imageKishore Kumar ( 2015-08-03 11:27:53 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-07-31 04:56:57 -0500

Seen: 1,326 times

Last updated: Aug 03 '15