OpenCV Jar file is not created after cmake/make commands

asked 2015-04-13 13:35:37 -0500

Gonzalo gravatar image

I'm trying to develop an application in JAVA, using Opencv 2.4.9 in a mac OS 10.10

But my problems are at the beginning with the OpenCV configuration....

I'm not able to create the JAR file into build/bin folder and I cannot understand the reasons...

This is the commands I wrote on the terminal, but they don't create any jar..

$ cd [PATH_TO_OPEN_CV_2_4_9]

$ mkdir build

$ cd build/

$ cmake -G "Unix Makefiles" -D CMAKE_INSTALL_PREFIX=[PATH_TO_OPENCV_DIRECTORY] -D CMAKE_OSX_ARCHITECTURES=x86_64 -D BUILD_PERF_TESTS=OFF -D BUILD_opencv_legacy=NO ..

$make -j3

$ make install

I didn't receive errors... but the jar does not exist

can you help me?

edit retag flag offensive close merge delete

Comments

if it wasn't build, there must have been something in the cmake output, that would explain it, so, can you add it ?

berak gravatar imageberak ( 2015-04-13 14:28:41 -0500 )edit

I berak... I tried many times to do the operation in some ways... and at the end I found the JAR file in the folder....... not so sure how, but problem solved for me

Gonzalo gravatar imageGonzalo ( 2015-04-17 18:47:17 -0500 )edit