Ask Your Question
0

Error building opencv-3.0.0-beta on Jetson TK1

asked 2015-01-30 16:55:30 -0500

I'm getting the following error building opencv-3.0.0-beta on my Jetson TK1.

[ 32%] [ 33%] [ 33%] [ 33%] Building CXX object modules/core/CMakeFiles/opencv_core.dir/src/opengl.cpp.o Building CXX object modules/core/CMakeFiles/opencv_core.dir/src/persistence.cpp.o Building CXX object modules/core/CMakeFiles/opencv_core.dir/src/cuda_info.cpp.o Building CXX object modules/core/CMakeFiles/opencv_core.dir/src/convert.cpp.o In file included from /home/ubuntu/opencv-3.0.0-beta/modules/core/src/opengl.cpp:48:0: /usr/local/cuda-6.5/include/cuda_gl_interop.h:64:2: error: #error Please include the appropriate gl headers before including cuda_gl_interop.h #error Please include the appropriate gl headers before including cuda_gl_interop.h ^ make[2]: * [modules/core/CMakeFiles/opencv_core.dir/src/opengl.cpp.o] Error 1 make[2]: Waiting for unfinished jobs.... make[1]: [modules/core/CMakeFiles/opencv_core.dir/all] Error 2 make: * [all] Error 2

I used the following for cmake . -DWITH_EXAMPLES=ON -DENABLE_NEON:BOOL=ON -DCUDA_ARCH_BIN=3.2

What am I doing wrong? Thanks in advance for any help!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-02-02 19:10:39 -0500

The cmake line was actually this... cmake -DWITH_CUDA=ON -DCUDA_ARCH_BIN="3.2" -DCUDA_ARCH_PTX="" -DBUILD_TESTS=OFF -DBUILD_PERF_TESTS=OFF ..

I managed to get a successful build when I used ccmake .. and turned off WITH_OPENCL

Not sure if that's a good thing to do or not.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-01-30 16:55:30 -0500

Seen: 1,273 times

Last updated: Feb 02 '15