Ask Your Question
1

OpenCV 245 first build errors..

asked 2013-04-24 14:49:25 -0500

OrkunK gravatar image

Hi. I download the sources of opencv-2.4.5 and I follow the tutorial (on the opencv site for windows) about the installing my own libraries everything ok I create the opencv.sln file with cmake then I opened it with visual studio 2010 professional and I click the build solution but just 9 succeeded the more of the 200 was failed and most of the errors about tbbd.lib not found and opencv_core245d.lib not found with LNK1104 error. I'm trying to solve it for how many days. I've tried to show the ways of files... Anyone can help please this is about my dissertation.

edit retag flag offensive close merge delete

Comments

Hi. I am having the exact same issue. Does anyone have a solution for this yet? Thanks.

adnanhk gravatar imageadnanhk ( 2013-07-02 14:10:58 -0500 )edit

I'm not using Windows now but I solved it with disabled the BUILD_TBB flag then enabled the WITH_TBB flag and added pathes from cmake gui.

OrkunK gravatar imageOrkunK ( 2014-11-05 05:16:40 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-04-24 15:28:31 -0500

You did not set your windows system PATH variable to include the lib directories for openCV and TBB. If it doesn't know where to get them, it won't compile I am guessing.

edit flag offensive delete link more

Comments

thank you @StevenPuttemans. I set system path variable to include all of the modules example eigen, openexr, qt, tbb... just there is a point I'm not understanding, I want to create my libs and there is no opencv_core245d.lib in nowhere my opencv folder I'm also trying to create the libraries why the compiler asking me it or them? I've searched tbbd.lib and opencv_core245d.lib and did not find anything.

OrkunK gravatar imageOrkunK ( 2013-04-24 15:49:18 -0500 )edit

I guess someone with building openCV experience will be needed here :D

StevenPuttemans gravatar imageStevenPuttemans ( 2013-04-24 16:39:19 -0500 )edit

Please PM me if this gets solved, I am having the exact same problems. Maybe the "#include "tbb\someheader.h" directives need to be with <tbb\someheader.h> so that compiler/linker looks in PATH and not PWD?

If this is the case... http://vasir.net/blog/ubuntu/replace_string_in_multiple_files Love Linux!

Overloaded_Operator gravatar imageOverloaded_Operator ( 2013-12-20 00:55:22 -0500 )edit

It's too late I know sorry I'm a lot busy and working on another projects for one year. I was trying to build TBB and OpenCV with BUILD_TBB flag. I've done now and I'm using OpenCV on Ubuntu 12.04 LTS but I've another questions about creating samples and training with samples I am researching to find similar questions but if I don't I'll write a new question thanks everyone

OrkunK gravatar imageOrkunK ( 2014-11-05 05:13:06 -0500 )edit

You are welcome. As to others, do make new questions, all of us have more experience now and can help you to solve them! Thanks for the update orkunk!

StevenPuttemans gravatar imageStevenPuttemans ( 2014-11-05 05:46:24 -0500 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-04-24 14:49:25 -0500

Seen: 355 times

Last updated: Apr 24 '13