Ask Your Question
1

Error: install openCV-3.0.0-beta on Ubuntu 14.10

asked 2015-01-16 12:42:10 -0500

REZA gravatar image

updated 2015-01-17 06:00:00 -0500

how can solve this ERROR?????

[ 55%] Built target opencv_imgcodecs
Scanning dependencies of target opencv_videoio
[ 56%] [ 56%] [ 56%] [ 56%] [ 56%] Building CXX object modules/videoio/CMakeFiles/opencv_videoio.dir/src/cap_ffmpeg.cpp.o
Building CXX object modules/videoio/CMakeFiles/opencv_videoio.dir/src/cap_v4l.cpp.o
Building CXX object modules/videoio/CMakeFiles/opencv_videoio.dir/src/cap_dc1394_v2.cpp.o
Building CXX object modules/videoio/CMakeFiles/opencv_videoio.dir/src/cap.cpp.o
Building CXX object modules/videoio/CMakeFiles/opencv_videoio.dir/src/cap_images.cpp.o
Linking CXX shared library ../../lib/libopencv_videoio.so
/usr/bin/ld: /usr/local/lib/libavcodec.a(avpacket.o): relocation R_X86_64_32 against `.rodata.str1.8' can not be used when making a shared object; recompile with -fPIC
/usr/local/lib/libavcodec.a: error adding symbols: Bad value
collect2: error: ld returned 1 exit status
modules/videoio/CMakeFiles/opencv_videoio.dir/build.make:194: recipe for target 'lib/libopencv_videoio.so.3.0.0' failed
make[2]: *** [lib/libopencv_videoio.so.3.0.0] Error 1
CMakeFiles/Makefile2:2503: recipe for target 'modules/videoio/CMakeFiles/opencv_videoio.dir/all' failed
make[1]: *** [modules/videoio/CMakeFiles/opencv_videoio.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
Linking CXX shared library ../../lib/libopencv_video.so
[ 56%] Built target opencv_video
Makefile:136: recipe for target 'all' failed
make: *** [all] Error 2
edit retag flag offensive close merge delete

Comments

Can you please provide your CMAKE configuration? Also please go to the github repository and download the latest 3.0 branch. The beta branch wasn't stable and tons of fixes have been introduced so far.

StevenPuttemans gravatar imageStevenPuttemans ( 2015-01-17 06:01:37 -0500 )edit

i had use of many way for CMake configuration, e.g. CMake-GUI with default parameter. and use different version of opencv, i.e. opencv-3-0.0-beta, opencv-2.4.2, github repository opencv. BUT all of this has same error on different stage. however, i think find problem

Thanks for your comment.

REZA gravatar imageREZA ( 2015-01-18 01:28:08 -0500 )edit

Problem Solved. i change Ubuntu version of 14.10 to 14.04.1 and problem has solved. so i think Ubuntu 14.10 is not consistent with OpenCV.

REZA gravatar imageREZA ( 2015-01-18 01:46:29 -0500 )edit

Hmmm normally changing versions of Ubuntu should not intervene with the code base. We got systems with Ubuntu 14.10 running here with OpenCV installed.

StevenPuttemans gravatar imageStevenPuttemans ( 2015-01-18 02:54:28 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
0

answered 2015-01-22 15:42:35 -0500

I am having the same exact problem but with the latest 3.0 branch, beside downgrading Ubuntu version, what could be a possible solution?

Here's the cmake file: https://www.dropbox.com/s/wa2dnym9tzo...

Thanks for any help

edit flag offensive delete link more

Comments

Could you amend the make output?

StevenPuttemans gravatar imageStevenPuttemans ( 2015-01-23 01:46:52 -0500 )edit
0

answered 2015-06-10 15:19:53 -0500

I'm also facing the exact same issue on Ubuntu 14.04 64 bit. Any chances any of you figured out how to get it working?

edit flag offensive delete link more

Comments

By downloading the latest release instead of the beta ! :D

StevenPuttemans gravatar imageStevenPuttemans ( 2015-06-11 02:20:58 -0500 )edit
0

answered 2015-02-17 08:42:28 -0500

i am also bothered with the same output. Im using Ubuntu 14.10 on a 64 bit system and i followed a tutorial on this site. "http://rodrigoberriel.com/2014/10/installing-opencv-3-0-0-on-ubuntu-14-04/" .He stated that i change a command for Ubuntu 14.10 version that include WITH_FFMPEG=OFF in step 3. But im stuck at this very point. Could you help me out with the process without degrading my Ubuntu. Im a beginner with Ubuntu and Opencv so it kinda difficult to get through this installation. Please help Thanks

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2015-01-16 12:42:10 -0500

Seen: 2,528 times

Last updated: Feb 17 '15