Ask Your Question
0

Issue in OpenCV 2.3.0/2.4.0 installation on Ubuntu 11.04 [closed]

asked 2012-08-08 09:49:45 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >50 is welcome to improve it.

Hi

I have been trying to install OpenCV 2.3.0/2.4.0 on Ubuntu 11.04. OpenCV gets installed but it complains in run time with below error :

OpenCV Error: Unspecified error (The function is not implemented. Rebuild the library with Windows, GTK+ 2.x or Carbon support. If you are on Ubuntu or Debian, install libgtk2.0-dev and pkg-config and rerun make.

Now i wasnt able to successfully install libgtk2.0-dev. I did not get the package by apt-get then tried by synaptic but it denies the installation because it was conflicting with packages of higher versions like libxfixes3,libxursor1,libxdamage1,libxcomposite1 and others.

I tried removing these and then gnome desktop was not coming up, it messed the whole display. I then rollbacked the reinstalled them from console.

I initially thought this might be due to broken dependencies but those are alright. Even tried with synaptic which out rightly rejects installation due to unmet dependies and a different version present.

Please suggest any work around for this.

Thanks

edit retag flag offensive reopen merge delete

Closed for the following reason not a real question by Kirill Kornyakov
close date 2012-09-30 03:34:39.428814

1 answer

Sort by ยป oldest newest most voted
0

answered 2012-08-09 10:11:15 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >50 is welcome to improve it.

Resolved ! Thanks :)

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2012-08-08 09:49:45 -0500

Seen: 450 times

Last updated: Aug 09 '12