Ask Your Question

Can't run sample on Tegra K1 / Nexus 9

asked 2014-11-15 04:46:43 -0600

ARGroup-1415 gravatar image

updated 2015-01-16 02:30:00 -0600

berak gravatar image


we tried the OpenCV Sample-face-detection from TADP and couldn't run it on Nexus 9. It works on Android-Devices lower than 5.

OpenCVManager: Device information

Tegra5 OS version: REL (5.0), API 21 Installed packaged Built-in OpenCV library(optimized) Library version: rev 1
Target hardware: Tegra OCV 2.4 pack armeabi-v7a (safe to remove)
Libray version: rev 1
Target hardware: arm7a

Error: Package not found OpenCV library package was not found! Try to install it?

If we click "yes" -> Page not found (in Play Store)

Has anyone an idea?


edit retag flag offensive close merge delete


I'm having the same issue. Did you manage to solve it?

lights gravatar imagelights ( 2014-12-03 21:46:10 -0600 )edit

I have the same problem. I'm trying to run the same sample in my galaxy s6, which has an ARMv8-A architecture. I think this might be the problem. Also, the same thing happens when I try to click yes, it takes me to a page not found in play store. Don't know how to fix it yet... :(

davides10 gravatar imagedavides10 ( 2015-05-15 13:01:32 -0600 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2015-01-14 21:13:52 -0600

I wonder if this is due to the fact that the Denver, which Nexus 9 has, is on ARMv8-A. I hope the next release of Android4OpenCV contains a pre-built binary for this architecture.

In the meantime, you could possibly build it by setting the target architecture as ''arm64-v8a" with this latest CMake toolchain file.

I didn't try it yet though, it would be helpful if somebody who tried this can share his/her experience. Thanks!

edit flag offensive delete link more

Question Tools



Asked: 2014-11-15 04:46:43 -0600

Seen: 1,062 times

Last updated: Jan 14 '15