Ask Your Question

opencv_core241d.dll missing

asked 2012-11-17 11:06:22 -0500

I have set up OpenCV 2.4.3 on Windows 7 following this guide: Which has worked fine, all the examples work etc. However when I tried to create a new project in Visual Studio 2010 following this guide: I get the following run-time error: "The program can't start because opencv_core241d.dll is missing from your computer. Try reinstalling the program to fix this problem." The dlls are in fact there, but I don't know why my program can't find them. I have tried googling the answer, and have tried various things including adding the location to the system path, to no avail. How do I solve this problem?

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted

answered 2012-11-19 02:08:24 -0500

Daniil Osokin gravatar image

Hi! In error message needed 2.4.1 version of this lib, and you have 2.4.3 version of OpenCV. May be, you should modify linker paths.

edit flag offensive delete link more


No, I installed the latest version. For now Ive just had to put the necessary dlls in the same folder as my solution.

notromit gravatar imagenotromit ( 2012-11-22 05:19:26 -0500 )edit

If you run not in Visual Studio, you should put this necessary .dlls in folder with your .exe. It's a regular case for project with .dlls.

Daniil Osokin gravatar imageDaniil Osokin ( 2012-11-22 05:37:20 -0500 )edit

Placing dll's in the project folder is actually the worst approach you could do to my knowledge. It is mostly the case that the actual system configuration is wrong :)

StevenPuttemans gravatar imageStevenPuttemans ( 2013-07-19 05:12:17 -0500 )edit

answered 2013-07-19 05:11:00 -0500

There was actually a problem with the current guide. A bugfix for this has already been applied. Basically the guide tells you to configure the lib and include folder wrongly. To have the correct fix, look at the pull request here.

Does this fix the problem?

edit flag offensive delete link more

answered 2013-07-18 23:03:03 -0500

DexEr gravatar image

has the problem been resolved...? If some-how you have managed to solve the problem please elaborate the steps cause this is the same error that is coming even while using open cv 2.4.6

edit flag offensive delete link more


did you set your bin path to the environment path?

Pinky gravatar imagePinky ( 2013-07-18 23:38:05 -0500 )edit

yes i have

DexEr gravatar imageDexEr ( 2013-08-12 12:43:31 -0500 )edit
Login/Signup to Answer

Question Tools


Asked: 2012-11-17 11:06:22 -0500

Seen: 617 times

Last updated: Jul 19 '13