Ask Your Question

Missing opencv_core243d.dll

asked 2013-02-04 22:54:15 -0600

jrpharis gravatar image

I am using a 32 bit version of VS2010 on W7 64 bit OS. I have installed opencv2.4.3 to my root directory C:. I am having issues with VS seeing the .lib files. When I try to debug I get the error:

"The program can't start because opencv_core243.dll is missing from your computer. Try reinstalling the program to fix this problem."

I have added C:\opencv\build\x86\vc10\bin to my system path using Windows' 'Edit environment variables for your account' utility. I have added a property sheet to Win32 | Debug where under Common Properties > C/C++ > General I added C:\opencv\build\include to the Additional Include Directories. Then under Common Properties > Linker > General I added C:\opencv\build\x86\vc10\lib to Additional Library Directories, then all of the *d.lib files from this directory to the Additional Dependencies under Linker > Input.

Is there something I am missing to get the binaries on the system path? Any help would be greatly appreciated. I have been fighting with this for a week now! Thanks.

edit retag flag offensive close merge delete


UPDATE: I went ahead and tried everything with the x64 directories even though my version of VS2010 is 32 bits and when I start debugging it seems to have taken care of the missing opencv_243d.dll, but now I get all kinds of linker errors:

error LNK2019: unresolved external symbol _cvWaitKey referenced in function _main

error LNK2019: unresolved external symbol "void __cdecl cv::imshow(class std::basic_string<char,struct std::char_traits<char>,class std::allocator<char> > const &,class cv::_InputArray const &)" (?imshow@cv@@YAXABV?$basic_string@DU?$char_traits@D@std@@V?$allocator@D@2@@std@@ABV_InputArray@1@@Z) referenced in function _main

And 25 more just as cryptic. If I have the project pointing to the correct directories and lib files, why can't it find them?

jrpharis gravatar imagejrpharis ( 2013-02-04 23:22:48 -0600 )edit

For opencv2.4.4 with visual studio 2012 on win8, I got the same error. The following thread helped me to fix it:

MMLuqman gravatar imageMMLuqman ( 2013-03-27 14:40:48 -0600 )edit

3 answers

Sort by ยป oldest newest most voted

answered 2013-02-10 10:39:00 -0600

jrpharis gravatar image

I was able to get it going. It turns out I was only adding system variables, I didn't have access on my company laptop to change the path directly. I used the free program Path Editor and everything worked great.

edit flag offensive delete link more


For opencv2.4.4 with visual studio 2012 on win8, I got the same error. The following thread helped me to fix it:

MMLuqman gravatar imageMMLuqman ( 2013-03-27 14:40:36 -0600 )edit

answered 2013-02-05 04:21:06 -0600

yogeshopencv gravatar image

HI, Everything seems okay here.I suggest you to check *d.dll files names that you added to Additional Dependencies under Linker > Input and the ones that are really present in your bin folder.They may have different digits in their name.

edit flag offensive delete link more

answered 2013-02-05 10:38:16 -0600

emptypixel gravatar image

Are you certain that the folder you added to the system path contains the required dll's ?

My easy setup: I have added a DLL folder in my C;\, and added to it every version of the opencv dll's (release and debug, win32 and x64); I have added a system environment variable pointing to that c:\DLL folder.

As for the errors in your comment, they seem to indicate missing lib... so check the Additional Dependencies, under Linker-> Input.

It may be easier (to change, to read...) if you place these dependencies in a property sheet as well.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2013-02-04 22:54:15 -0600

Seen: 15,236 times

Last updated: Feb 10 '13