Ask Your Question
0

Linking issue after update to version 2.4.3 on iOS

asked 2012-11-15 10:41:35 -0500

goe gravatar image

Hi, I was working with a previous release of opencv (2.4.0) on iOS. It worked fine, but yesterday I updated the code because I needed the new parallel_for functionality. After the update, the core functions worked fine, and the new functionalities were working, but now other modules are crashing on linking time. For example, if I add CascadeClassifier object, the linker throws errors. Any idea?

edit retag flag offensive close merge delete

Comments

I have used my own compiled framework, and the precompiled framework dowloaded from here: http://opencv.org/

goe gravatar imagegoe ( 2012-11-15 10:51:13 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2012-11-19 01:58:13 -0500

goe gravatar image

Ok! The answer was simple: in the project configuration, set "C++ Standard Library" option as "libc++ (LLVM standard library with C++11 support)". And this fixed the problem. ;)

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2012-11-15 10:41:35 -0500

Seen: 246 times

Last updated: Nov 19 '12