Ask Your Question
3

opencv 3.0 build error

asked 2014-08-23 03:46:31 -0500

amiltonwong gravatar image

Hi, all,

I had downloaded opencv 3.0 master branch. (Before I had installed basic required packages for installing opencv)

After cmake it, and make, I came across the following build error :

==================================================================

[ 61%] Building CXX object modules/calib3d/CMakeFiles/opencv_calib3d.dir/src/posit.cpp.o

[ 61%] Building CXX object modules/calib3d/CMakeFiles/opencv_calib3d.dir/src/homography_decomp.cpp.o

[ 61%] Building CXX object modules/calib3d/CMakeFiles/opencv_calib3d.dir/src/p3p.cpp.o

[ 61%] Building CXX object modules/calib3d/CMakeFiles/opencv_calib3d.dir/src/ptsetreg.cpp.o

[ 61%] Building CXX object modules/calib3d/CMakeFiles/opencv_calib3d.dir/src/dls.cpp.o

/root/Downloads/opencv-3.0/modules/calib3d/src/dls.cpp:11:31: fatal error: Eigen/Eigenvalues: No such file or directory

compilation terminated.

make[2]: * [modules/calib3d/CMakeFiles/opencv_calib3d.dir/src/dls.cpp.o] Error 1

make[1]: * [modules/calib3d/CMakeFiles/opencv_calib3d.dir/all] Error 2

make: * [all] Error 2

root@ubuntu:~/Downloads/opencv-3.0/release#

==================================================================

It seems that the package cannot find "Eigen/Eigenvalues". Does it mean that I missed some prerequisites in my system? Hope someone could give me some suggestion to fix it?

P.S. My system is Ubuntu 12.04

Best regards,

Milton

edit retag flag offensive close merge delete

Comments

2

Hello Milton, I faced the same issue, even with EIGEN on the correct location it didn't seem to build. Solution is to build with -D WITH_EIGEN=OFF for now. However there are several other errors popping up. Already provided some fixes for it.. take a look here!

StevenPuttemans gravatar imageStevenPuttemans ( 2014-08-23 04:30:23 -0500 )edit

just to add to the confusion, i don't have eigen (well, not where cmake can see it), and even leaving the switch ON compiles fine. seems to be a prob only if the eigen lib is actually present ?

berak gravatar imageberak ( 2014-08-23 04:49:15 -0500 )edit

hmmm I even had the problem when eigen wasn't installed. I did built with CUDA QT SAMPLES ... probably a dependency throwing up?

StevenPuttemans gravatar imageStevenPuttemans ( 2014-08-23 04:52:10 -0500 )edit
1

oh, neither qt, nor cuda here, maybe that narrows it down

berak gravatar imageberak ( 2014-08-23 04:56:52 -0500 )edit
1

Thanks the suggestions from all of you. I shifted to build the opencv-3.0-alpha, rather than master branch on github repositories. Then the building process succeeded.

amiltonwong gravatar imageamiltonwong ( 2014-08-24 03:49:52 -0500 )edit

About the EIGEN problem, just fixed it on my system. Basically you need to assure that once you built Eigen library manual that the Eigen folder and the unsupported/Eigen folder is copied to /usr/local/include and has reading rights. After that it builded perfectly for me. Other fixes for the master are due to get merged and then a stable building master should be achieved!

StevenPuttemans gravatar imageStevenPuttemans ( 2014-08-28 08:21:07 -0500 )edit

I do not have eigen3, only eigen2 exists. Does anyone know how I can get it?

Ch gravatar imageCh ( 2017-01-31 03:44:26 -0500 )edit

On linux, like Ubuntu, simply do sudo apt-get install eigen2-dev eigen3-dev

StevenPuttemans gravatar imageStevenPuttemans ( 2017-01-31 06:13:54 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
3

answered 2015-05-25 07:07:59 -0500

smokeink gravatar image

Had the same problem, in my case it's because cmake-gui detected eigen2 instead of eigen3 . So in cmake-gui i just changed EIGEN_INCLUDE_PATH from /usr/include/eigen3 to /usr/include/eigen2 then it worked, it compiled successfully opencv 3.0.0-rc1 (it's not the latest commit, i first ran git checkout 3.0.0-rc1).

edit flag offensive delete link more

Comments

Just confirmed, also works with the latest commit. Thank you for the update, this can indeed also be a reason of this problem occuring.

StevenPuttemans gravatar imageStevenPuttemans ( 2015-05-27 08:03:30 -0500 )edit

when and how i do this exactly? sorry my ignorance

Mandy gravatar imageMandy ( 2015-09-01 10:59:07 -0500 )edit
1

I tried to install OpenCV 3.0.0-rc1 on Ubuntu 14.04 LTS 64-bit and I faced this problem. I noticed that in /usr/include/ there was only eigen2 library. So, I installed libeigen3-devfrom command line and then the installation builded correctly. (http://packages.ubuntu.com/source/tru...)

ale_Xompi gravatar imageale_Xompi ( 2016-01-07 06:32:03 -0500 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2014-08-23 03:46:31 -0500

Seen: 9,551 times

Last updated: May 25 '15