Make uEye compatible with Aruco / OpenCV?

asked 2014-08-18 14:15:54 -0600

Hello everyone, I have been trying to get the uEye camera to interface with the OpenCV library Aruco, following the instructions here: I have made it to the last line, $ ./aruco_test_board live board.yml camera.yml 0.025 but evertime I run it I get Could not Open Video. My uEye camera works with its own demos and ImageView, and shows up as ueye under ls /dev. I have tried on two machines, running Ubuntu 12.04 and 14.04, ROS Hydro and Indigo respectively. Same error for both. Does anyone know how to resolve this?

edit retag flag offensive close merge delete


Since Aruco is NOT an official package of OpenCV rather a package that uses OpenCV internally. I guess you will need to point your problem to a forum that focuses on Aruco rather then OpenCV...

StevenPuttemans gravatar imageStevenPuttemans ( 2014-08-19 05:03:11 -0600 )edit

I don't think so, OpenCV will not see the uEye either, and Aruco applications all reference OpenCV definitions. Do you know how to get OpenCV to detect uEye?

hdejarnette gravatar imagehdejarnette ( 2014-08-19 15:36:54 -0600 )edit