Ask Your Question

Build OpenCV framework

asked 2014-07-26 00:43:03 -0600

Skuenstler gravatar image

updated 2014-07-26 01:14:26 -0600

berak gravatar image

Hi, I use the following procedure to build the opencv-framework: link1 It all works well and the framework is built sucessfully ! But in XCode, thats where the problem occurrs: There I add the framework according to the following procedure: link2. This also performes. But now the issue: Whenever I open Xcode with a project where I incorporated the opencv-framework, the opencv2 framework is no longer recognized by XCode upon opening XCode ! The following error message appears :

'opencv2/opencv.hpp' file not found

I have an annoying workarround, that is: Unlinking the framework and linking it again. Thats how the Xcode project runs just fine. But whenever I close and re-open XCode project again, that's when the error occurrs again !!

I am using XCode 5.1.1 on MacOS Mavericks 10.9.4. The opencv2-framework has the version

Questions: I) can the framework be built on one location (with procedure described in link1 above) and then copied into another location where it is added into the Xcode project ? Or does the building process already needs to be in the final location where the opencv2-framework is going to sit ? (and if so, how could one download a finished opencv2-framework and not building it from scratch ??) II) Could the toolchains be corrupt ? III) Could the header-search-paths be wrong ?? How do you correctly set the Header search paths ?? (is $(inherited) correct ??) (i.e. /Applications/ IV) If I run Step2 of the link1 creation process, it sais: "ln: Developer/Developer: File exists" Is this correct ? Or is that step somehow corrupt and not doing the symbolic links.

Pretty desperate for help! Thank you very much for any hint !

edit retag flag offensive close merge delete


By the way, two weeks ago, this all worked fine (opening closing Xcode project did not affect the recognition of the opencv2-framework). All I did is repeating link1-procedure and linking it according to link2-procedure. But now, this error whenever I open Xcode :/

Skuenstler gravatar imageSkuenstler ( 2014-07-26 00:47:14 -0600 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2014-08-31 06:50:53 -0600

Skuenstler gravatar image

The solution was tedious but this link helped a lot !! I did not realize that the opencv-framework was not fully built. The python building framework process did acutally compile saing Build SUCCESSFULLY...but the newly created ios/opencv2.framework/Versions/A/opencv File was only 8 kB (instead of MB) big. Again, link the did it for me...!

edit flag offensive delete link more

Question Tools


Asked: 2014-07-26 00:43:03 -0600

Seen: 451 times

Last updated: Aug 31 '14