Enable SSE2

asked 2014-06-14 17:40:04 -0500

NitinPrasad gravatar image

updated 2014-06-14 17:41:03 -0500

I'm running on a machine (Intel i5) that runs SSE2, but when I run OpenCV code the CV_SSE2 sections never run. Is there an easy way to enable this without re installing?

I'm running Ubuntu 13.04 and Eclipse CDT, but I can change to command line if necessary.

Thanks

edit retag flag offensive close merge delete

Comments

1

if you build from src, cmake -D ENABLE_SSE=ON is set by default

you used some stupid package manager, that disabled it ?

berak gravatar imageberak ( 2014-06-14 17:47:26 -0500 )edit

I thought it is the ON by default.

Abid Rahman K gravatar imageAbid Rahman K ( 2014-06-15 02:04:23 -0500 )edit

@berak, any idea which code is run while useOptimized() = True? Is it SSE code?

Abid Rahman K gravatar imageAbid Rahman K ( 2014-06-15 02:14:16 -0500 )edit

sorry, i already regret the remark above, as i got no idea besides the cmake thing ;(

berak gravatar imageberak ( 2014-06-15 02:21:07 -0500 )edit