CMAKE failing to set SSE2 in VS build

asked 2016-03-06 05:33:19 -0500

Boogaloo gravatar image

The first time I installed OpenCV 3.0 I did not set the check boxes for SSE2 etc., so I ran CMAKE again and checked them, after generating without errors, and SSE2 set, I loaded the project into Visual Studio Community 2015 and all of the SSE2 settings disabled.

If anyone has a solution for this, please post!

edit retag flag offensive close merge delete

Comments

  • did you rebuild the opencv libs (also the INSTALL project), after changing the cmake settings ?
  • are you sure, you're using your locally built libs / headers (build/install for additional include dirs, libs, etc)
berak gravatar imageberak ( 2016-03-06 05:43:21 -0500 )edit

But CMAKE should change the project settings after being run, so when I open it all in VS the settings should be correct. There is no way to do this on all the different solutions in VS, and there are scores of them so doing it manually would take a long time.

Boogaloo gravatar imageBoogaloo ( 2016-03-06 05:50:14 -0500 )edit