Build OpenCV 2.4.5 in Sparc and Java Errors

asked 2014-06-13 07:24:46 -0600

josemgm gravatar image

updated 2014-06-13 07:29:55 -0600

berak gravatar image


I've building OpenCV 2.4.5 in Sparc SunOS 5.10. Build is correct with following cmake.


pkg-config --modversion opencv command shows 2.4.5

But, when trying to call javacv libraries from java application running under jboss 5.1.0 GA, get the following error.

Caused by java.lang.UnsatisfiedLinKerror: no jniopencv_core in java.library.path

Caused by java.lang.UnsatisfiedLinKerror: /usr/local/lib/ java: fatal: relocation error: file /usr/local/lib/ symbol _ZNSs4_Rep20_S_empty_rep_storageE: referenced symbol not found.

How can i solved it?

EDIT: After execute crle command, get the following error.

NoClassDefFoundError: Could not initialize class com.googlecode.javacv.cpp.opencv_highgui

I've got javacv.jar javacpp.jar and javacv-linux-x86_64.jar in my application.ear/lib and works under Windows/Linux

Thanks in advance

Best regards

edit retag flag offensive close merge delete


Note: With OpenCV 2.4.9, i've got the same error.

Edit: it's a compatibility problem with javacv libs and SunOS?

josemgm gravatar imagejosemgm ( 2014-06-16 10:52:55 -0600 )edit