Ask Your Question
1

How to compile OpenCV 2.4.8 static libs using MinGW on Windows 7

asked 2014-02-27 15:05:23 -0500

tmanthey gravatar image

In Cmake I set BUILD_SHARED_LIBS to false but the results are exactly equal to the results when setting the flag to true. GCC Version is 4.8.1.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-02-28 04:26:49 -0500

tmanthey gravatar image

Not a typo but still my fault.

I am using CmakeUI.

What I did was:

  1. Press Configure
  2. Uncheck BUILD_SHARED_LIBS
  3. Press Generate
  4. Compile

That is one jump short. Correct order is: Start CMakeUI

  1. Press Configure
  2. Uncheck BUILD_SHARED_LIBS
  3. Press Configure
  4. Press Generate
  5. Compile
edit flag offensive delete link more
3

answered 2014-02-28 00:25:12 -0500

Elix gravatar image

I think you are having a syntax error. You should set BUILD_SHARED_LIBS to off. This is the way how opencv can be compiled as static libs.

edit flag offensive delete link more

Comments

Not the solution, but still it helped very much to find it.

tmanthey gravatar imagetmanthey ( 2014-02-28 04:28:01 -0500 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2014-02-27 15:05:23 -0500

Seen: 2,874 times

Last updated: Feb 28 '14