Ask Your Question
0

Trying to run OpenCV samples on Samsung Galaxy S4: dark screen

asked 2013-12-23 14:18:34 -0500

IZ73 gravatar image

updated 2013-12-24 13:17:54 -0500

I am trying to run OpenCV samples from Eclipse on a brand new Samsung Galaxy S4. I tried a couple of them: 15-puzzle, face detection and image manipulation, and in all cases the behavior is the same: the app seems to be running, since I get each sample's menu, but the screen is dark. Did not see any error messages in logcat or console when I launched them. Do I need to change certain settings of the project and/or on the device?

Thanks

UPDATE: Just tried image manipulation on S3 (Android 4.1.3) and it seems to be working fine, or at least it's not giving me the dark screen. So does look like some sort of problem with the S4 device and/or with Android 4.3.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2013-12-23 18:43:06 -0500

Linke Seitentasche gravatar image
edit flag offensive delete link more
1

answered 2013-12-29 05:37:15 -0500

OpenCV4Android 2.4.8 SDK with the issue fix has been already published. You can install fixed Manager apks from SDK or beta testing package from Google Play. OpenCV team uses this feature to publish new packages. The new version of Manager is published as beta for developers first. If there is no issues, we publish it in production in a week or two. It is done to decrease impact of any regressions for end application users.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-12-23 14:18:34 -0500

Seen: 957 times

Last updated: Dec 29 '13