Ask Your Question
5

OpenCV IOS6 - armv7s support

asked 2012-09-20 06:20:56 -0500

jhensler gravatar image

When will there be support of armv7s? If i am using the current OpenCv2.framework, i get the following error:

ld: file is universal (2 slices) but does not contain a(n) armv7s slice: /Users/test/test-project/opencv2.framework/opencv2 for architecture armv7s clang: error: linker command failed with exit code 1 (use -v to see invocation)

Thanks, Jens

edit retag flag offensive close merge delete

Comments

Same issue here. if you find anything can you please notify me? thanks a lot

youssef gravatar imageyoussef ( 2012-09-21 07:29:42 -0500 )edit

Same here.

mongoose gravatar imagemongoose ( 2012-09-22 08:47:42 -0500 )edit

Same problem here. Can you give some indications please? Thanks!

CV_Max gravatar imageCV_Max ( 2012-09-25 10:59:05 -0500 )edit

Guys, do you know that you're supposed to +1 this question? Please do it if you really want to bring attention to the issue!!

Kirill Kornyakov gravatar imageKirill Kornyakov ( 2012-09-25 11:17:41 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
3

answered 2012-10-23 21:30:54 -0500

AlexanderShishkov gravatar image

updated 2012-10-24 01:44:57 -0500

Kirill Kornyakov gravatar image

OpenCV 2.4.3 will support armv7s platform. Look at this commit: https://github.com/Itseez/opencv/commit/2dba13f7d47921a6ab203e969c952d2e47b9b183

You can use similar solution for your OpenCV version.

edit flag offensive delete link more
2

answered 2012-09-25 18:35:28 -0500

Hammer gravatar image

I don't know when official support is going to appear, but I had the same problem and I got something working. Hopefully it works for you too.

Here is a link to my solution

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2012-09-20 06:20:56 -0500

Seen: 1,306 times

Last updated: Oct 24 '12