How to fix error: unrecognized command-line option ‘--param=ipcp-unit-growth=100000’

asked 2020-11-20 09:05:20 -0500

Peppe gravatar image

updated 2020-11-20 09:26:15 -0500

Hi, im new to this and im trying to compile opencv4 and i get this error whe i run make -j4

error: unrecognized command-line option ‘--param=ipcp-unit-growth=100000’

Here is some more lines:

make[1]: Entering directory '/home/peppe/opencv/build' make[2]: Entering directory '/home/peppe/opencv/build' make[2]: Leaving directory '/home/peppe/opencv/build' [ 4%] Built target libwebp make[2]: Entering directory '/home/peppe/opencv/build' make[2]: Leaving directory '/home/peppe/opencv/build' [ 6%] Built target libjasper make[2]: Entering directory '/home/peppe/opencv/build' make[2]: Leaving directory '/home/peppe/opencv/build' [ 8%] Built target IlmImf make[2]: Entering directory '/home/peppe/opencv/build' make[2]: Leaving directory '/home/peppe/opencv/build' [ 10%] Built target libprotobuf make[2]: Entering directory '/home/peppe/opencv/build' make[2]: Leaving directory '/home/peppe/opencv/build' [ 10%] Built target quirc make[2]: Entering directory '/home/peppe/opencv/build' make[2]: Leaving directory '/home/peppe/opencv/build' make[2]: Entering directory '/home/peppe/opencv/build' [ 10%] Building CXX object 3rdparty/carotene/hal/carotene/CMakeFiles/carotene_objs.dir/src/absdiff.cpp.o c++: error: unrecognized command-line option ‘--param=ipcp-unit-growth=100000’; did you mean ‘--param=ipa-cp-unit-growth=’? make[2]: * [3rdparty/carotene/hal/carotene/CMakeFiles/carotene_objs.dir/build.make:63: 3rdparty/carotene/hal/carotene/CMakeFiles/carotene_objs.dir/src/absdiff.cpp.o] Error 1 make[2]: Leaving directory '/home/peppe/opencv/build' make[1]: [CMakeFiles/Makefile2:4833: 3rdparty/carotene/hal/carotene/CMakeFiles/carotene_objs.dir/all] Error 2 make[1]: Leaving directory '/home/peppe/opencv/build' make: ** [Makefile:163: all] Error 2

edit retag flag offensive close merge delete

Comments

are you cross-compiling, or on the device ?

can you give us some more lines around the error ? (so we can maybe see, which module / file it is from ?)

it'll be also less confusing with make -j1

berak gravatar imageberak ( 2020-11-20 09:20:27 -0500 )edit

@Peppe. What is ur rpi model?

supra56 gravatar imagesupra56 ( 2020-11-20 09:38:52 -0500 )edit
1

Its a rpi 4 model-B 4gb

Peppe gravatar imagePeppe ( 2020-11-20 09:39:47 -0500 )edit

That fine. Which link did u download? Can u list cmake? Otherwise cleansed sd card and then reinstall opencv4.

supra56 gravatar imagesupra56 ( 2020-11-20 09:42:55 -0500 )edit

either you're using outdated opencv source (pull fresh from github), or your system has trouble figuring out what compiler you are using. https://github.com/opencv/opencv/blob...

crackwitz gravatar imagecrackwitz ( 2020-11-20 09:47:26 -0500 )edit

One problem is did u update and upgrade b4 u install OpenCV 4? R u using python?

supra56 gravatar imagesupra56 ( 2020-11-20 09:47:37 -0500 )edit