Initialization worked with Android 4.2.2 not working with 4.3

asked 2013-11-10 01:44:40 -0500

Dimuthu gravatar image

updated 2013-11-10 14:43:35 -0500

Hi, I'm preparing for my masters degree final project and I recently updated my mobile device (Galaxy S4) into Android 4.3. (bad call) My OpenCV project was working well, but now it's not starting up anymore. (Using JavaCameraView) I also tried the OpenCV tutorials available in the SDK directory and they also not starting up.

I'm totally **ed up now since I have to complete everything within 2 weeks:( Tried uninstalling 4.3 update, but couldn't so far. At the moment trying to build OpenCV from source expecting a solution is there..

Any help is greatly appriciated!!!

EDIT: And the error is 11-11 02:01:40.432: I/Adreno-EGL(31134): <qegldrvapi_eglinitialize:316>: EGL 1.4 QUALCOMM build: (CL4169980)

11-11 02:01:40.432: I/Adreno-EGL(31134): OpenGL ES Shader Compiler Version: 17.01.10.SPL

11-11 02:01:40.432: I/Adreno-EGL(31134): Build Date: 09/26/13 Thu

11-11 02:01:40.442: W/Adreno-EGL(31134): <qegldrvapi_eglcreatecontext:2340>: EGL_BAD_CONFIG

11-11 02:01:40.442: E/OpenCV_for_Tegra(31134): Canot create OpenGL context

11-11 02:01:40.543: I/ActivityManager(700): Process org.opencv.engine:OpenCVEngineProcess (pid 31134) (adj 0) has died.

I tried both static loading and Async loading.

edit retag flag offensive close merge delete

Comments

Having the same problem! Help us OpenCV! xD

Caio gravatar imageCaio ( 2013-11-19 12:25:26 -0500 )edit

I have raised an issue for this. http://code.opencv.org/issues/3372 Galaxy note 3 is also affected by this. (http://code.opencv.org/issues/3368)

Dimuthu gravatar imageDimuthu ( 2013-12-02 06:12:15 -0500 )edit

I'm also having this problem. My App links to the OpenCV-2.4.9-android-sdk version and my device is a Galaxy Nexus with Android 4.3 and the latest OpenCV Manager from Google Play.

Although I'm using the JavaCameraView, I get this error when the code reaches this line:

OpenCVLoader.initAsync(OpenCVLoader.OPENCV_VERSION_2_4_9, this, mLoaderCallback);

I also tried to use OpenCVLoader.initDebug(), but it returns false and fails as well.

05-06 17:50:44.834: E/OpenCV_for_Tegra(6538): Cannot create OpenGL context

cagiva gravatar imagecagiva ( 2015-05-06 23:23:10 -0500 )edit