Ask Your Question
0

Error: Couldn't load opencv_java from loader...

asked 2013-05-07 12:18:44 -0500

Maria Tereza Blanco gravatar image

Hi, I'm new in programming and I need help.

Caused by: java.lang.UnsatisfiedLinkError: Couldn't load opencv_java from loader dalvik.system.PathClassLoader[dexPath=/data/app/com.ndu.mobile.darwinwallet-1.apk,libraryPath=/data/app-lib/com.ndu.mobile.darwinwallet-1]: findLibrary returned null

I don't can understand. I downloaded OPENCV 2.4.5 and I'm trying to execute the Darwin Wallet project in Android (Eclipse). The link to downloaded Darwin Wallet project is https://github.com/matthill/darwinwallet The error is because the Opencv must to be for Android and don't Windows? Nor Meet the OpenCV.mk I need can get this application, thanks for help!!!!!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2013-05-08 01:05:15 -0500

"java.lang.UnsatisfiedLinkError: Couldn't load opencv_java" exception means that opencv_java.so was not packed to your apk file before installation. Windows pack of OpenCV contains sources for all platforms and binaries for Windows only. In your case you need to build Android part manually or download ready OpenCV4Android SDK from SourceForge. Also I recommend you to start from this page.

As I see Darwin Wallet project was implemented with OpenCV 2.4.0. Binary and source compatibility approach in OpenCV had been introduced since version 2.4.2. It means that actual version of OpenCV can be incompatible with the project. In this case you need to downgrade OpenCV to 2.4.0.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-05-07 12:18:44 -0500

Seen: 3,686 times

Last updated: May 08 '13