link opencv inc and lib in rpio

asked 2020-01-24 01:40:34 -0500

dineshlama gravatar image

updated 2020-01-24 04:50:40 -0500

I have just installed the opencv 4 in raspberry pi 4 version. But while making it link to the opencv program i\m getting some trouble. ther error message is: image description here is my cmakelists.txt:

cmake_minimum_required(VERSION 3.1)

project(tests)

SET(OpenCV_DIR /installation/OpenCV-/lib/cmake/opencv4)
set(CMAKE_CXX_STANDARD 11)
set(CMAKE_CXX_STANDARD_REQUIRED TRUE)

find_package(OpenCV 4 REQUIRED)
include_directories(/installation/OpenCV-/include/opencv4)

add_executable(tests DisplayImage.cpp)
target_link_libraries(tests /installation/OpenCV-/lib)
edit retag flag offensive close merge delete

Comments

please try again, and add the error messages as TEXT to your question.

berak gravatar imageberak ( 2020-01-24 02:42:59 -0500 )edit
1

what's so hard to understand with "as TEXT" ?

(screenshots are useless here, ppl can't quote you, it can't be indexed for search, etc.)

berak gravatar imageberak ( 2020-01-24 04:29:38 -0500 )edit
2

ok i've done that but since i'me re installing the opencv right now i can't get same error. but i have pasted the cmakelists file.

dineshlama gravatar imagedineshlama ( 2020-01-24 04:48:54 -0500 )edit

Today, I re-installed it and I got an error @99% stating that python 2 and cmakelist. Then I went back to build's folder and deleted it, and then re-do cmake again. And it worked right now. I'm using 3b/3b+/4b.

supra56 gravatar imagesupra56 ( 2020-01-24 20:45:13 -0500 )edit