does JetsonTX2 support CV.dnn ?

asked 2019-10-17 08:52:29 -0500

redhwan gravatar image

updated 2019-10-17 08:57:23 -0500

I ran this code Real-time object detection with deep learning and OpenCV, Numbers of the frame per second were low about 5.

I asked there yesterday about OpenCV4Tegra doesn't support GPU the answer was that "OpenCV4Tegra in jetpack has disabled gpu for a long time"

I ran the code with three OpenCV versions are:

1- ros-kinetic-opencv3 .........CPU

2- OpenCV4Tegra.................CPU according to yesterday's answer.

3- OpenCV with GPU, I built it from source, everything is OK but all of the versions are very very slow and there is not any observable difference among them. the numbers of the frame per second about 3- 4.6

python
Python 2.7.12 (default, Oct  8 2019, 14:14:10) 
[GCC 5.4.0 20160609] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import cv2
>>> cv2.__version__
'3.4.1-dev'
>>>

I bought the Jetson for getting a high frame per second.

believe me that the computer is faster than Jetson.

I guess that the reason is the installation of OpenCV was wrong!

my system:

NVIDIA Jetson TX2

L4T 28.2.1 [ 3.2.1 ]

Board: t186ref

Ubuntu 16.04.6 LTS

Kernel Version: 4.4.38-tegra

CUDA 9.0.252

sudo ./tegrastats 
RAM 1238/7846MB (lfb 1339x4MB) CPU [0%@345,off,off,0%@345,1%@345,1%@345] EMC_FREQ 15%@204 GR3D_FREQ 0%@140 APE 150 BCPU@45.5C MCPU@45.5C GPU@44C PLL@45.5C Tboard@40C Tdiode@43C PMIC@100C thermal@44.9C VDD_IN 1757/1816 VDD_CPU 229/202 VDD_GPU 152/152 VDD_SOC 381/392 VDD_WIFI 57/78 VDD_DDR 443/441

You can see here

python
Python 2.7.12 (default, Oct  8 2019, 14:14:10) 
[GCC 5.4.0 20160609] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import cv2
>>> print(cv2.getBuildInformation())

General configuration for OpenCV 3.4.1-dev =====================================
  Version control:               3.4.1-9-gec0bb66-dirty

  Extra modules:
    Location (extra):            /home/nvidia/opencv_contrib/modules
    Version control (extra):     3.4.1

  Platform:
    Timestamp:                   2019-10-17T00:54:00Z
    Host:                        Linux 4.4.38-tegra aarch64
    CMake:                       3.5.1
    CMake generator:             Unix Makefiles
    CMake build tool:            /usr/bin/make
    Configuration:               RELEASE

  CPU/HW features:
    Baseline:                    NEON FP16
      required:                  NEON
      disabled:                  VFPV3

  C/C++:
    Built as dynamic libs?:      YES
    C++ Compiler:                /usr/bin/c++  (ver 5.4.0)
    C++ flags (Release):         -fsigned-char -W -Wall -Werror=return-type -Werror=non-virtual-dtor -Werror=address -Werror=sequence-point -Wformat -Werror=format-security -Wmissing-declarations -Wundef -Winit-self -Wpointer-arith -Wshadow -Wsign-promo -Wuninitialized -Winit-self -Wno-narrowing -Wno-delete-non-virtual-dtor -Wno-comment -fdiagnostics-show-option -pthread -fomit-frame-pointer -ffunction-sections -fdata-sections    -fvisibility=hidden -fvisibility-inlines-hidden -O3 -DNDEBUG  -DNDEBUG
    C++ flags (Debug):           -fsigned-char -W -Wall -Werror=return-type -Werror=non-virtual-dtor -Werror=address -Werror=sequence-point -Wformat -Werror=format-security -Wmissing-declarations -Wundef -Winit-self -Wpointer-arith -Wshadow -Wsign-promo -Wuninitialized -Winit-self -Wno-narrowing -Wno-delete-non-virtual-dtor -Wno-comment -fdiagnostics-show-option -pthread -fomit-frame-pointer -ffunction-sections -fdata-sections    -fvisibility=hidden -fvisibility-inlines-hidden -g  -O0 -DDEBUG -D_DEBUG
    C Compiler:                  /usr/bin/cc
    C flags (Release):           -fsigned-char -W -Wall -Werror=return-type -Werror=non-virtual-dtor -Werror=address -Werror=sequence-point -Wformat -Werror=format-security -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wundef -Winit-self -Wpointer-arith -Wshadow -Wuninitialized -Winit-self -Wno-narrowing -Wno-comment -fdiagnostics-show-option ...
(more)
edit retag flag offensive close merge delete

Comments

cv2.__version__ '3.4.1-dev'

that's REALLY old

berak gravatar imageberak ( 2019-10-17 09:25:43 -0500 )edit
1

the official version is 3.3.1 for JetsonTX2 with Jetpack3.2.1 here

redhwan gravatar imageredhwan ( 2019-10-17 09:30:29 -0500 )edit